summaryrefslogtreecommitdiff
path: root/net/kpopup/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-04-30 13:20:05 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-04-30 13:20:05 +0000
commitd946eb8abd37a59cf49c8379114ec954991e3830 (patch)
treeab295c750e8f427e6634b2836e93d916cb9e1a44 /net/kpopup/Makefile
parentInstall gc_cpp.h and gc_allocator.h to the correct location. (diff)
Add kpopup, KDE program for sending and receiving WinPopup messages
PR: 51549 Submitted by: Frerich Raabe <frerich.raabe@gmx.de>
Diffstat (limited to 'net/kpopup/Makefile')
-rw-r--r--net/kpopup/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/kpopup/Makefile b/net/kpopup/Makefile
new file mode 100644
index 000000000000..7638f9e8b8ca
--- /dev/null
+++ b/net/kpopup/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: KPopup
+# Date created: Apr 4, 2003
+# Whom: Frerich Raabe <frerich.raabe@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= kpopup
+PORTVERSION= 0.9.1
+CATEGORIES= net kde
+MASTER_SITES= http://www.henschelsoft.de/kpopup/
+
+MAINTAINER= frerich.raabe@gmx.de
+COMMENT= KDE program for sending and receiving MS Windows WinPopup messages
+
+RUN_DEPENDS= smbclient:${PORTSDIR}/net/samba
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/kpopup/misc.cpp \
+ ${WRKSRC}/kpopup/make_popup.cpp ${WRKSRC}/kpopup/main.cpp
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g'
+
+.include <bsd.port.mk>