summaryrefslogtreecommitdiff
path: root/net/kdetelnet/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
commitdbba8af6447e625aae93ec45e619acbecb4ab189 (patch)
treed696a8c2d3e835a743132aa1f6a5cc0557d1c435 /net/kdetelnet/Makefile
parentUpdate to the actual release version of 9.1.1. If you're using (diff)
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Diffstat (limited to '')
-rw-r--r--net/kdetelnet/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/net/kdetelnet/Makefile b/net/kdetelnet/Makefile
index 296c560ee2ef..d331a451b223 100644
--- a/net/kdetelnet/Makefile
+++ b/net/kdetelnet/Makefile
@@ -14,15 +14,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
-USE_QT= yes
+USE_KDELIBS_VER=1
USE_GMAKE= yes
USE_AUTOMAKE= yes
CONFIGURE_ENV= QTDIR="${X11BASE}" KDEDIR="${LOCALBASE}"
-CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/X11/qt \
- --with-extra-includes=${X11BASE}/include \
- --with-extra-libs=${LOCALBASE}/lib \
+CONFIGURE_ARGS= --with-extra-includes=${X11BASE}/include \
--program-transform-name='s,k,kde,'
post-extract: