summaryrefslogtreecommitdiff
path: root/net/isc-dhcp31-server/files/patch-includes::dhcpd.h
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-03-16 20:31:15 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-03-16 20:31:15 +0000
commitb77059fee230166d718075c75aefc81e483dfe5b (patch)
treefc6fe8ade1c97ac875e64603da3c6e22730e0d76 /net/isc-dhcp31-server/files/patch-includes::dhcpd.h
parentRemove Xft. This port has been renamed libXft. (diff)
Mega-update from maintainer:
isc-dhcp3-client/pkg-message updated isc-dhcp3-devel/pkg-plist updated from PR#61620 isc-dhcp3-relay/pkg-message rewritten to reflect rcNG change isc-dhcp3-relay/pkg-plist etc/rc.isc-dhcrelay.conf deleted etc/rc.d/isc-dhcrelay.sh.sample renamed to etc/rc.d/isc-dhcrelay.sh isc-dhcp3-server/Makefile PORTREVISION bumped USE_RC_SUBR added *_SUB added pre-everything added (WITHOUT_INTERFACE_POLLING cond added) patch-scripts and patch-pkgmessage (! -devel cond) updated patch-site-conf and patch-rc-scripts added install-startup-files now install etc/rc.d/isc-dhcpd.sh instead of etc/rc.d/isc-dhcpd.sh.sample display-message updated (! -devel cond) isc-dhcp3-server/pkg-message rewritten to reflect rcNG change isc-dhcp3-server/pkg-plist etc/rc.isc-dhcpd.conf deleted etc/rc.d/isc-dhcpd.sh.sample renamed to etc/rc.d/isc-dhcpd.sh isc-dhcp3-server/files/isc-dhcpd.sh.sample isc-dhcp3-server/files/isc-dhcrelay.sh.sample both converted to rcNG isc-dhcp3-server/files/patch-freebsd synced w/ -current isc-dhcp3-server/files/patch-site.conf CLIENT_PATH added CFLAGS synced w/ -current isc-dhcp3-server/patch-client::clparse.c isc-dhcp3-server/patch-client::dhclient.8 new files synced w/ -current isc-dhcp3-server/patch-client::dhclient.c new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/patch-client::dhclient.conf new file isc-dhcp3-server/patch-common::dhcp-options.5 new file synced w/ -current isc-dhcp3-server/patch-common::discover.c new file from PR#61011 isc-dhcp3-server/patch-common::dispatch.c new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/files/patch-common::parse.c fix time_t issues on little-endian 64-bit platforms isc-dhcp3-server/patch-dst::Makefile.dist new file from PR#61620 isc-dhcp3-server/patch-includes::cf::freebsd.h new file synced w/ -current (-DRESCUE unused right now) isc-dhcp3-server/patch-includes::dhcpd.h new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/files/rc.isc-dhcpd.conf.sample isc-dhcp3-server/files/rc.isc-dhcrelay.conf.sample deleted files PR: 57943, 61011, 61620 Submitted by: sec@42.org, andy@fud.org.nz, kaa@in-line.ru, des, ru
Diffstat (limited to '')
-rw-r--r--net/isc-dhcp31-server/files/patch-includes::dhcpd.h56
1 files changed, 56 insertions, 0 deletions
diff --git a/net/isc-dhcp31-server/files/patch-includes::dhcpd.h b/net/isc-dhcp31-server/files/patch-includes::dhcpd.h
new file mode 100644
index 000000000000..afedaa818647
--- /dev/null
+++ b/net/isc-dhcp31-server/files/patch-includes::dhcpd.h
@@ -0,0 +1,56 @@
+--- includes/dhcpd.h.orig Mon Feb 10 02:22:46 2003
++++ includes/dhcpd.h Wed Mar 3 16:20:09 2004
+@@ -99,6 +99,9 @@
+ (((x) >> OPTION_HASH_EXP) & \
+ (OPTION_HASH_PTWO - 1))) % OPTION_HASH_SIZE;
+
++#define NOLINK 0
++#define HAVELINK 1
++
+ enum dhcp_shutdown_state {
+ shutdown_listeners,
+ shutdown_omapi_connections,
+@@ -783,6 +786,11 @@
+ unsigned remote_id_len; /* Length of Remote ID. */
+
+ char name [IFNAMSIZ]; /* Its name... */
++ int ieee80211; /* True if media is ieee802.11 */
++ int havemedia; /* True if we have a media table */
++ int linkstate; /* True if we have link */
++ int polling; /* True if polling is enabled */
++ int forcediscover; /* True if a discover is needed */
+ int index; /* Its index. */
+ int rfdesc; /* Its read file descriptor. */
+ int wfdesc; /* Its write file descriptor, if
+@@ -1845,6 +1853,9 @@
+ extern const char *path_dhclient_pid;
+ extern char *path_dhclient_script;
+ extern int interfaces_requested;
++#ifdef ENABLE_POLLING_MODE
++extern int polling_interval;
++#endif
+
+ extern struct client_config top_level_config;
+
+@@ -1858,12 +1869,21 @@
+ void send_decline PROTO ((void *));
+
+ void state_reboot PROTO ((void *));
++#ifdef ENABLE_POLLING_MODE
++void state_background PROTO ((void *));
++void state_polling PROTO ((void *));
++#endif
+ void state_init PROTO ((void *));
+ void state_selecting PROTO ((void *));
+ void state_requesting PROTO ((void *));
+ void state_bound PROTO ((void *));
+ void state_stop PROTO ((void *));
+ void state_panic PROTO ((void *));
++
++#ifdef __FreeBSD__
++void set_ieee80211 PROTO ((struct interface_info *));
++#endif
++int interface_active PROTO ((struct interface_info *));
+
+ void bind_lease PROTO ((struct client_state *));
+