summaryrefslogtreecommitdiff
path: root/net/isc-dhcp30-server/files/patch-common::parse.c
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-03-16 20:31:15 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-03-16 20:31:15 +0000
commitb77059fee230166d718075c75aefc81e483dfe5b (patch)
treefc6fe8ade1c97ac875e64603da3c6e22730e0d76 /net/isc-dhcp30-server/files/patch-common::parse.c
parentRemove Xft. This port has been renamed libXft. (diff)
Mega-update from maintainer:
isc-dhcp3-client/pkg-message updated isc-dhcp3-devel/pkg-plist updated from PR#61620 isc-dhcp3-relay/pkg-message rewritten to reflect rcNG change isc-dhcp3-relay/pkg-plist etc/rc.isc-dhcrelay.conf deleted etc/rc.d/isc-dhcrelay.sh.sample renamed to etc/rc.d/isc-dhcrelay.sh isc-dhcp3-server/Makefile PORTREVISION bumped USE_RC_SUBR added *_SUB added pre-everything added (WITHOUT_INTERFACE_POLLING cond added) patch-scripts and patch-pkgmessage (! -devel cond) updated patch-site-conf and patch-rc-scripts added install-startup-files now install etc/rc.d/isc-dhcpd.sh instead of etc/rc.d/isc-dhcpd.sh.sample display-message updated (! -devel cond) isc-dhcp3-server/pkg-message rewritten to reflect rcNG change isc-dhcp3-server/pkg-plist etc/rc.isc-dhcpd.conf deleted etc/rc.d/isc-dhcpd.sh.sample renamed to etc/rc.d/isc-dhcpd.sh isc-dhcp3-server/files/isc-dhcpd.sh.sample isc-dhcp3-server/files/isc-dhcrelay.sh.sample both converted to rcNG isc-dhcp3-server/files/patch-freebsd synced w/ -current isc-dhcp3-server/files/patch-site.conf CLIENT_PATH added CFLAGS synced w/ -current isc-dhcp3-server/patch-client::clparse.c isc-dhcp3-server/patch-client::dhclient.8 new files synced w/ -current isc-dhcp3-server/patch-client::dhclient.c new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/patch-client::dhclient.conf new file isc-dhcp3-server/patch-common::dhcp-options.5 new file synced w/ -current isc-dhcp3-server/patch-common::discover.c new file from PR#61011 isc-dhcp3-server/patch-common::dispatch.c new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/files/patch-common::parse.c fix time_t issues on little-endian 64-bit platforms isc-dhcp3-server/patch-dst::Makefile.dist new file from PR#61620 isc-dhcp3-server/patch-includes::cf::freebsd.h new file synced w/ -current (-DRESCUE unused right now) isc-dhcp3-server/patch-includes::dhcpd.h new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/files/rc.isc-dhcpd.conf.sample isc-dhcp3-server/files/rc.isc-dhcrelay.conf.sample deleted files PR: 57943, 61011, 61620 Submitted by: sec@42.org, andy@fud.org.nz, kaa@in-line.ru, des, ru
Diffstat (limited to 'net/isc-dhcp30-server/files/patch-common::parse.c')
-rw-r--r--net/isc-dhcp30-server/files/patch-common::parse.c22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/isc-dhcp30-server/files/patch-common::parse.c b/net/isc-dhcp30-server/files/patch-common::parse.c
new file mode 100644
index 000000000000..637d69e7f41b
--- /dev/null
+++ b/net/isc-dhcp30-server/files/patch-common::parse.c
@@ -0,0 +1,22 @@
+--- common/parse.c.orig 2 Sep 2003 11:01:23 -0000
++++ common/parse.c 22 Feb 2004 10:44:52 -0000
+@@ -414,6 +414,7 @@
+ {
+ const char *val;
+ enum dhcp_token token;
++ int32_t num;
+
+ token = next_token (&val, (unsigned *)0, cfile);
+ if (token != NUMBER) {
+@@ -421,9 +422,9 @@
+ skip_to_semi (cfile);
+ return;
+ }
+- convert_num (cfile, (unsigned char *)timep, val, 10, 32);
++ convert_num (cfile, (unsigned char *)&num, val, 10, 32);
+ /* Unswap the number - convert_num returns stuff in NBO. */
+- *timep = ntohl (*timep); /* XXX */
++ *timep = ntohl (num);
+
+ parse_semi (cfile);
+ }