summaryrefslogtreecommitdiff
path: root/net/idnkit/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-03-23 06:25:10 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-03-23 06:25:10 +0000
commit18ed949e180d8efc56e8c47778e558b30a40a5ab (patch)
treedaed8104656ec72dbb790f9d0b1329082a127a00 /net/idnkit/Makefile
parentNew MASTER_SITE and WWW reference. (diff)
Add idnkit-1.0, a library to handle internationalized domain names.
Diffstat (limited to 'net/idnkit/Makefile')
-rw-r--r--net/idnkit/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/net/idnkit/Makefile b/net/idnkit/Makefile
new file mode 100644
index 000000000000..ab3478ef09f6
--- /dev/null
+++ b/net/idnkit/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: idnkit
+# Date created: 19 March 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= idnkit
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.nic.ad.jp/ja/idn/idnkit/download/sources/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A library to handle internationalized domain names
+
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libiconv=${LOCALBASE} \
+ --enable-runidn
+
+INSTALLS_SHLIB= yes
+
+MAN1= idnconv.1 \
+ runidn.1
+MAN3= libidnkit.3 \
+ libidnkitlite.3
+MAN5= idn.conf.5 \
+ idnalias.conf.5 \
+ idnrc.5
+MANCOMPRESSED= no
+
+DOCS_EN= ChangeLog NEWS README
+DOCS_JA= README.ja
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>