summaryrefslogtreecommitdiff
path: root/net/glflow/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-13 13:32:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-13 13:32:52 +0000
commite943dff556243382303d9ef05eabca873c06443a (patch)
tree9458206adcbf374a7f6cb0c2903e8544598b716a /net/glflow/Makefile
parent- Use more correct path for fonts, to be exact, use X prefix and (diff)
Add glflow, a DoS detection tool written with speed in mind.
It detects attacks on high speed links through real-time NetFlow aggregation and analysis. PR: ports/69011 Submitted by: David Thiel <lx@redundancy.redundancy.org>
Diffstat (limited to 'net/glflow/Makefile')
-rw-r--r--net/glflow/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/glflow/Makefile b/net/glflow/Makefile
new file mode 100644
index 000000000000..786b65c8779b
--- /dev/null
+++ b/net/glflow/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: glflow
+# Date created: 2004-07-12
+# Whom: David Thiel (lx@redundancy.redundancy.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= glflow
+PORTVERSION= 0.0.4
+CATEGORIES= net security
+MASTER_SITES= http://night.rdslink.ro/dudu/glflow/
+DISTNAME= glFlow-${PORTVERSION}
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A NetFlow tool for detecting DoS attacks
+
+PLIST_FILES= bin/glflow
+PORTDOCS= README
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/glflow ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>