summaryrefslogtreecommitdiff
path: root/net/ggsd/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-02-27 18:04:08 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-02-27 18:04:08 +0000
commite52e93b676746083552aaf13a08c485417913998 (patch)
treedb401f076245e86eae13381683ce840b64f4629d /net/ggsd/Makefile
parentChange MASTER_SITES and maintainer's e-mail address. (diff)
GGSD is a Generic Graphical Server Daemon. It allows anyone to make a simple
script and then start a network server to run it. http://devplanet.fastethernet.net/files.html (committers note: this would be good for testing scripts that are later used with tcp_wrappers) PR: ports/10109 Submitted By: Dima Sivachenko <dima@Chg.RU>
Diffstat (limited to 'net/ggsd/Makefile')
-rw-r--r--net/ggsd/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/ggsd/Makefile b/net/ggsd/Makefile
new file mode 100644
index 000000000000..84ba643afa26
--- /dev/null
+++ b/net/ggsd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ggsd
+# Version required: 0.1
+# Date created: 14 February 1999
+# Whom: Dima Sivachenko <dima@chg.ru>
+#
+# $Id: $
+#
+
+DISTNAME= ggsd
+PKGNAME= ggsd-0.1
+CATEGORIES= net
+MASTER_SITES= http://devplanet.fastethernet.net/ \
+ http://www.FreeBSD.org/~billf/distfiles/
+# ftp://ftp.gpad.ac.ru/pub/FreeBSD/distfiles/
+EXTRACT_SUFX= .tar
+
+MAINTAINER= dima@chg.ru
+
+LIB_DEPENDS= gtk11.1:${PORTSDIR}/x11-toolkits/gtk11
+
+WRKSRC= ${WRKDIR}/GGSD
+EXTRACT_CMD= ${TAR}
+EXTRACT_BEFORE_ARGS= -xf
+EXTRACT_AFTER_ARGS= # empty
+
+do-install:
+
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/ggsd ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/ggsd
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ggsd
+ @ ${INSTALL_DATA} ${WRKSRC}/example.scr ${PREFIX}/share/doc/ggsd
+.endif
+
+.include <bsd.port.mk>