summaryrefslogtreecommitdiff
path: root/net/coda6_server/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-09 12:26:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-09 12:26:54 +0000
commit38d3364d0da1368ce3bfeb15465bff143ebd8fbc (patch)
tree43e563a2082e5ca71645aca1e0ee003473ffb60c /net/coda6_server/Makefile
parentUpgrade to 4.13, which contains better xinerama support, and a few other (diff)
New ports: coda6_server and coda6_client
I've just added the kernel support for Coda 6.x. It would be great to have the server and client in the ports collection to make it easier for people to experiment with. PR: ports/56623 Submitted by: Tim Robbins <tim@robbins.dropbear.id.au>
Diffstat (limited to 'net/coda6_server/Makefile')
-rw-r--r--net/coda6_server/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
new file mode 100644
index 000000000000..ced80dbfff27
--- /dev/null
+++ b/net/coda6_server/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: coda-server-6
+# Date created: 9 september 2003
+# Whom: Tim Robbins
+
+# $FreeBSD$
+
+PORTNAME= coda
+PORTVERSION= ${CODA_VERSION}
+PORTREVISION= 1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/coda/src/
+PKGNAMESUFFIX= -${CODA_SUITE}
+DISTNAME= coda-${PORTVERSION}
+
+MAINTAINER?= tim@robbins.dropbear.id.au
+COMMENT= Server programs for a replicated high-performance network file system
+
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+ lwp.2:${PORTSDIR}/devel/lwp \
+ rpc2.4:${PORTSDIR}/devel/rpc2 \
+ rvm.2:${PORTSDIR}/devel/rvm
+
+CONFLICTS= coda-server-5.*
+
+ALL_TARGET= coda
+INSTALL_TARGET= ${CODA_SUITE}-install
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS?= --sysconfdir=${PREFIX}/etc/rc.d
+
+CODA_SUITE?= server
+CODA_VERSION?= 6.0.2
+
+.include <bsd.port.pre.mk>
+
+.if ${CODA_SUITE} == client
+.if ${OSVERSION} < 501106
+IGNORE= "This version of FreeBSD lacks Coda 6.x kernel support"
+.endif
+.endif
+
+.include <bsd.port.post.mk>