summaryrefslogtreecommitdiff
path: root/net/amule-devel/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-15 07:13:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-15 07:13:05 +0000
commitad93e1744d92397e89fe16e02a3e307d45fec972 (patch)
tree779ce4e18a1fd6411b30098416fa2de80f6d8144 /net/amule-devel/Makefile
parentAdd p5-Text-Unicode, a perl module to transliterate Unicode text. (diff)
[NEW PORT] net/amule-devel (aMule 2.0.0rc7)
This port is designed to manage the "unstable" branch of aMule, currently aMule 2.0.0rc7. PR: ports/73502 Submitted by: Ganael LAPLANCHE <ganael.laplanche@martymac.com>
Diffstat (limited to 'net/amule-devel/Makefile')
-rw-r--r--net/amule-devel/Makefile81
1 files changed, 70 insertions, 11 deletions
diff --git a/net/amule-devel/Makefile b/net/amule-devel/Makefile
index b265a274bd69..fc83224ad0b9 100644
--- a/net/amule-devel/Makefile
+++ b/net/amule-devel/Makefile
@@ -6,36 +6,49 @@
#
PORTNAME= aMule
-PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTVERSION= 2.0.0rc7
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/amule/
+PKGNAMESUFFIX= -devel
MAINTAINER= ganael.laplanche@martymac.com
COMMENT= The all-platform eMule p2p client
LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2 \
- curl.3:${PORTSDIR}/ftp/curl
+ curl.3:${PORTSDIR}/ftp/curl \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
+# gd.4:${PORTSDIR}/graphics/gd
-CONFLICTS= aMule-devel-*
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+CONFLICTS= aMule-1*
USE_X_PREFIX= yes
USE_GNOME= gnomehier gnomehack gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-included-gettext \
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --disable-debug \
+ --without-included-gettext \
--with-libintl-prefix=${LOCALBASE} \
--with-libiconv-prefix=${LOCALBASE} \
--with-wx-config=${WX_CONFIG} \
--with-wxbase-config=${WX_CONFIG} \
--with-curl-config=${CURL_CONFIG} \
- --program-transform-name="s/ed2k/amule-ed2k-handler/"
+ --enable-embedded_crypto \
+ --enable-utf8-systray
+# --with-gdlib-prefix=${LOCALBASE} \
+# --with-gdlib-exec-prefix=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
OPTIONS= OPTIMIZE "Build with optimization" on \
- STATIC "Enable static linking" off
+ ED2K "Compile aMule ed2k links handler" on \
+ AMULECMD "Compile aMule command line client (+GUI)" on \
+ AMULEWEBSRV "Compile aMule WebServer (+GUI)" on \
+ CAS "Compile C aMule Statistics (+GUI)" on \
+ ALC "Compile aMule Link Creator (+GUI)" on
+# AMULEDAEMON "Compile aMule daemon version (+GUI) - unsupported yet : needs wxGtk >= 2.5.1" on
WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
CURL_CONFIG?= ${LOCALBASE}/bin/curl-config
@@ -43,12 +56,58 @@ CURL_CONFIG?= ${LOCALBASE}/bin/curl-config
.include <bsd.port.pre.mk>
# Configure options
-.if !defined(WITHOUT_OPTIMIZE)
-CONFIGURE_ARGS+= --enable-optimise
+.if defined(WITH_OPTIMIZE)
+CONFIGURE_ARGS+= --enable-optimize
+.else
+CONFIGURE_ARGS+= --disable-optimize
.endif
-.if defined(WITH_STATIC)
-CONFIGURE_ARGS+= --enable-static
+.if defined(WITH_ED2K)
+CONFIGURE_ARGS+= --enable-ed2k --program-transform-name="s/ed2k/amule-ed2k/"
+PLIST_SUB+= PL_ED2K=""
+.else
+CONFIGURE_ARGS+= --disable-ed2k
+PLIST_SUB+= PL_ED2K="@comment "
.endif
+.if defined(WITH_AMULECMD)
+CONFIGURE_ARGS+= --enable-amulecmd --enable-amulecmdgui
+PLIST_SUB+= PL_AMULECMD=""
+.else
+CONFIGURE_ARGS+= --disable-amulecmd --disable-amulecmdgui
+PLIST_SUB+= PL_AMULECMD="@comment "
+.endif
+
+.if defined(WITH_AMULEWEBSRV)
+CONFIGURE_ARGS+= --enable-webserver --enable-webservergui
+PLIST_SUB+= PL_AMULEWEBSRV=""
+.else
+CONFIGURE_ARGS+= --disable-webserver --disable-webservergui
+PLIST_SUB+= PL_AMULEWEBSRV="@comment "
+.endif
+
+.if defined(WITH_CAS)
+CONFIGURE_ARGS+= --enable-cas --enable-wxcas
+PLIST_SUB+= PL_CAS=""
+.else
+CONFIGURE_ARGS+= --disable-cas --disable-wxcas
+PLIST_SUB+= PL_CAS="@comment "
+.endif
+
+.if defined(WITH_ALC)
+CONFIGURE_ARGS+= --enable-alc --enable-alcc
+PLIST_SUB+= PL_ALC=""
+.else
+CONFIGURE_ARGS+= --disable-alc --disable-alcc
+PLIST_SUB+= PL_ALC="@comment "
+.endif
+
+#.if defined(WITH_AMULEDAEMON)
+#CONFIGURE_ARGS+= --enable-amule-daemon --enable-amule-gui
+#PLIST_SUB+= PL_AMULEDAEMON=""
+#.else
+#CONFIGURE_ARGS+= --disable-amule-daemon --disable-amule-gui
+#PLIST_SUB+= PL_AMULEDAEMON="@comment "
+#.endif
+
.include <bsd.port.post.mk>