summaryrefslogtreecommitdiff
path: root/net/FlowScan/Makefile
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2001-03-13 23:20:57 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2001-03-13 23:20:57 +0000
commit5b8fe0427bc1cf2b1a46c982b8fe47eb2ec304ae (patch)
tree04d12728b29b594b1c21a84a391d5bdd41b861fd /net/FlowScan/Makefile
parentnew port p5-Cflow (diff)
FlowScan is a tool to monitor and graph flow information from
Cisco and Riverstone routers in near real-time. Amonst many other things, FlowScan can measure and graph traffic for applications such as Napster. A sample of what FlowScan can do is at: http://wwwstats.net.wisc.edu WWW: http://net.doit.wisc.edu/~plonka/FlowScan/
Diffstat (limited to 'net/FlowScan/Makefile')
-rw-r--r--net/FlowScan/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/FlowScan/Makefile b/net/FlowScan/Makefile
new file mode 100644
index 000000000000..c18e371cbe06
--- /dev/null
+++ b/net/FlowScan/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: FlowScan
+# Date created: Di 13 Mär 2001 08:23:55 CET
+# Whom: andreas@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= FlowScan
+PORTVERSION= 1.006
+CATEGORIES= net
+MASTER_SITES= http://net.doit.wisc.edu/~plonka/FlowScan/
+
+MAINTAINER= andreas@freebsd.org
+
+BUILD_DEPENDS= ksh:${PORTSDIR}/shells/pdksh \
+ rrdtool:${PORTSDIR}/net/rrdtool \
+ cflowd:${PORTSDIR}/net/cflowd \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Boulder/Stream.pm:${PORTSDIR}/converter/p5-Boulder \
+ ${LOCALBASE}/lib/perl5/site_perl/${{PERL_VER}/ConfigReader/DirectiveStyle.pm:${PORTSDIR}/devel/p5-ConfigReader \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Table.pm:${PORTSDIR}/www/p5-HTML-Table \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Cflow.pm:${PORTSDIR}/net/p5-Cflow
+
+CFLOWD_FLOWSCAN_PATCH= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}/var/flows
+
+pre-install:
+ ${MKDIR} -p ${PREFIX}/var/flows/bin
+
+.include <bsd.port.mk>