summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2006-09-07 16:41:50 +0000
committerAndrej Zverev <az@FreeBSD.org>2006-09-07 16:41:50 +0000
commita730fd4e64dcf259d4e7f499456de25f837e807a (patch)
treefc20668bf8f1d2e0d82d3620087d6a9c30af944c /net-p2p
parent- Update to 0.6.2 (diff)
microdc is a command-line based Direct Connect client that uses the
GNU Readline library for user interaction. It was developed from ground up and does not depend on any other program. Despite the command-line user interface, microdc was designed to be user friendly and simple to use. PR: ports/101899 Submitted by: Pankov Pavel <pankov_p@mail.ru>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/microdc/Makefile41
-rw-r--r--net-p2p/microdc/distinfo3
-rw-r--r--net-p2p/microdc/files/patch-filelist-in.c10
-rw-r--r--net-p2p/microdc/pkg-descr7
-rw-r--r--net-p2p/microdc/pkg-plist3
6 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 99a03b9bcb0e..b95b60c9b3eb 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -63,6 +63,7 @@
SUBDIR += linux-jigdo
SUBDIR += linux-overnet-core
SUBDIR += linuxdcpp
+ SUBDIR += microdc
SUBDIR += minder
SUBDIR += mldonkey
SUBDIR += mldonkey-core
diff --git a/net-p2p/microdc/Makefile b/net-p2p/microdc/Makefile
new file mode 100644
index 000000000000..c7679ad8c55a
--- /dev/null
+++ b/net-p2p/microdc/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: microdc
+# Date created: 2006-08-11
+# Whom: Pankov Pavel <pankov_p@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= microdc
+PORTVERSION= 0.11.0
+CATEGORIES= net-p2p
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pankov_p@mail.ru
+COMMENT= A command-line based Direct Connect client
+
+USE_GCC= 3.2+
+GNU_CONFIGURE= yes
+USE_ICONV= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+MAN1= ${PORTNAME}.1
+MANLANG= "" pl
+
+post-install:
+ @${MKDIR} ${MAN1PREFIX}/man/pl
+ @${MKDIR} ${MAN1PREFIX}/man/pl/man1
+ @${MV} ${MAN1PREFIX}/man/man1/${PORTNAME}.pl.1 ${MAN1PREFIX}/man/pl/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/net-p2p/microdc/distinfo b/net-p2p/microdc/distinfo
new file mode 100644
index 000000000000..3eeba4ff990f
--- /dev/null
+++ b/net-p2p/microdc/distinfo
@@ -0,0 +1,3 @@
+MD5 (microdc-0.11.0.tar.gz) = 2481e31495f7e809ea3fe7c460862b63
+SHA256 (microdc-0.11.0.tar.gz) = 57e12a6cfdf1feb5c526f4bfc9b250bb25c652e1ed81db28c9db1ab64af67b7e
+SIZE (microdc-0.11.0.tar.gz) = 517879
diff --git a/net-p2p/microdc/files/patch-filelist-in.c b/net-p2p/microdc/files/patch-filelist-in.c
new file mode 100644
index 000000000000..2a05ccb60a0b
--- /dev/null
+++ b/net-p2p/microdc/files/patch-filelist-in.c
@@ -0,0 +1,10 @@
+--- src/filelist-in.c-orig Wed Sep 21 23:28:10 2005
++++ src/filelist-in.c Fri Aug 11 23:21:51 2006
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #include <unistd.h>
+ #include <sys/signal.h>
++#include <sys/stat.h>
+ #include <stdbool.h>
+ #include "gettext.h" /* Gnulib/GNU gettext */
+ #define _(s) gettext(s)
diff --git a/net-p2p/microdc/pkg-descr b/net-p2p/microdc/pkg-descr
new file mode 100644
index 000000000000..4b0d788c81c0
--- /dev/null
+++ b/net-p2p/microdc/pkg-descr
@@ -0,0 +1,7 @@
+microdc is a command-line based Direct Connect client that uses the
+GNU Readline library for user interaction. It was developed from
+ground up and does not depend on any other program. Despite the
+command-line user interface, microdc was designed to be user
+friendly and simple to use.
+
+WWW: http://www.nongnu.org/microdc/
diff --git a/net-p2p/microdc/pkg-plist b/net-p2p/microdc/pkg-plist
new file mode 100644
index 000000000000..ec0e227ef9be
--- /dev/null
+++ b/net-p2p/microdc/pkg-plist
@@ -0,0 +1,3 @@
+bin/microdc
+%%NLS%%share/locale/pl/LC_MESSAGES/microdc.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/microdc.mo