summaryrefslogtreecommitdiff
path: root/net-p2p/py-bittorrent/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-04-05 05:56:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-04-05 05:56:44 +0000
commit4bddc5886922fce029d1895ad47523c0863471a7 (patch)
treef7033aff40ebb53dfbac40ca2fbe9bb7e3245d23 /net-p2p/py-bittorrent/Makefile
parenttypo USE_PERL -> USE_PERL5 (diff)
New port BitTorrent version 3.2.1b: A peer-to-peer tool for
distributing files written in Python
Diffstat (limited to 'net-p2p/py-bittorrent/Makefile')
-rw-r--r--net-p2p/py-bittorrent/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-p2p/py-bittorrent/Makefile b/net-p2p/py-bittorrent/Makefile
new file mode 100644
index 000000000000..4cf12ca9fbfc
--- /dev/null
+++ b/net-p2p/py-bittorrent/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: BitTorrent
+# Date created: Sun Mar 16 06:34:12 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BitTorrent
+PORTVERSION= 3.2.1.b
+CATEGORIES= net python
+MASTER_SITES= http://bitconjurer.org/BitTorrent/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(.)$/\1/}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A peer-to-peer tool for distributing files written in Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
+
+DOC_FILES= FAQ.txt INSTALL.unix.txt LICENSE.txt README.txt \
+ credits.txt todo.txt
+
+# required for GUI
+.ifndef(WITHOUT_GUI)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython
+
+PLIST_SUB+= GUI=''
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-nogui-patch-setup.py
+PLIST_SUB+= GUI='@comment '
+.endif
+
+pre-everything::
+.ifndef(WITHOUT_GUI)
+ @${ECHO_MSG} '===> Define WITHOUT_GUI to disable GUI installation'
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | \
+ ${XARGS} -x -n 10 \
+ ${REINPLACE_CMD} -E \
+ -e 's|/usr/bin/env python2|${LOCALBASE}/bin/python|'
+.ifdef(WITHOUT_GUI)
+ @${REINPLACE_CMD} -E \
+ -e 's|btdownloadgui.py|btdownloadcurses.py|' \
+ ${WRKSRC}/INSTALL.unix.txt
+.endif
+
+post-install:
+.ifndef(PORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>