summaryrefslogtreecommitdiff
path: root/net-p2p/mldonkey-devel/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-09 04:00:39 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-09 04:00:39 +0000
commit736a491d5ee5f01d59ca1039e11ed6c53ce15ca5 (patch)
treeaab9701cce2d422f6629733ac23475b65a9c2371 /net-p2p/mldonkey-devel/Makefile
parentUpdate references from net/mldonkey to net/mldonkey-devel after (diff)
o After repo copy from net/mldonkey
- Update to development version 2.5.28 patch kit j - Set myself as maintainer for the time being but allow previous maintainer to take over ASAP - Temporarily --disable-filetp per default since filetp is known to be broken on version 2.5.28* and prior - Deploy PORTDOCS - Add CONFLICTS on net/mldonkey{,-core,-gui} - NO_LATEST_LINK since this is a development version of net/mldonkey - DESCR: replace spaces with tabs PR: 75664 Repo copied by: marcus (portmgr)
Diffstat (limited to 'net-p2p/mldonkey-devel/Makefile')
-rw-r--r--net-p2p/mldonkey-devel/Makefile46
1 files changed, 30 insertions, 16 deletions
diff --git a/net-p2p/mldonkey-devel/Makefile b/net-p2p/mldonkey-devel/Makefile
index 34ee52c102c3..53a43e00cc15 100644
--- a/net-p2p/mldonkey-devel/Makefile
+++ b/net-p2p/mldonkey-devel/Makefile
@@ -6,28 +6,41 @@
#
PORTNAME= mldonkey
-PORTVERSION= 2.5.23
+PORTVERSION= 2.5.28.j
CATEGORIES+= net
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://download.berlios.de/pub/mldonkey/spiralvoice/cvs/
+PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}-${DOWNLOADVERSION}
-PATCH_SITES= http://www.schraegerpunkt.de/
-PATCHFILES= mldonkey-${DOWNLOADVERSION}-${PORTVERSION:C/.+\.//}.patch.gz
+PATCH_SITES= http://download.berlios.de/pub/mldonkey/spiralvoice/patchpacks/
+PATCHFILES= patch_pack${PORTVERSION:C/^.\..\.(.)/\1/:C/\.//}.gz
-MAINTAINER?= holger@e-gitt.net
+MAINTAINER?= lioux@FreeBSD.org
COMMENT?= A OCAML client for multiple peer-to-peer networks
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- autoconf213:${PORTSDIR}/devel/autoconf213
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-DOWNLOADVERSION=2.5.22
+DOWNLOADVERSION=${PORTVERSION:R}
+NO_LATEST_LINK= yes
+CONFLICTS= mldonkey-[0-9]* mldonkey-{core,gui}-[0.9]*
+
+USE_BZIP2= yes
+USE_AUTOCONF_VER= 213
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+ALL_TARGET= opt
+
CONFIGURE_ARGS= --enable-pthread --enable-ocamlver=3
+CONFIGURE_WRKSRC= ${WRKSRC}/config
+MAKE_ENV= OCAMLRUNPARAM="l=256M"
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${DOWNLOADVERSION}
-USE_GMAKE= yes
-ALL_TARGET= depend opt
+
+# XXX
+# filetp is known to be broken on version 2.5.28* and prior
+CONFIGURE_ARGS+= --disable-filetp
.if defined(WITHOUT_GUI)
.if defined(WITHOUT_CORE)
@@ -36,7 +49,7 @@ ALL_TARGET= depend opt
# have no 'without-' flag
CONFIGURE_ARGS+=--disable-gui
PLIST_SUB+= CORE="" GUI="@comment " GUICORE="@comment "
-PKGNAMESUFFIX= -core
+PKGNAMESUFFIX= -core-devel
.else
PLIST_SUB+= GUI=""
BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
@@ -44,7 +57,7 @@ BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
# we don't need lablgtk as RUN dependency, but we need gtk+glib
USE_GNOME= gtk12
.if defined(WITHOUT_CORE)
-PKGNAMESUFFIX= -gui
+PKGNAMESUFFIX= -gui-devel
PLIST_SUB+= CORE="@comment " GUICORE="@comment "
.else
PLIST_SUB+= CORE="" GUICORE=""
@@ -53,6 +66,7 @@ PLIST_SUB+= CORE="" GUICORE=""
DOCFILES= Authors.txt Bugs.txt ChangeLog Developers.txt FAQ.html \
Install.txt Readme.txt Todo.txt ed2k_links.txt
+PORTDOCS= ${DOCFILES}
.include <bsd.port.pre.mk>
@@ -62,12 +76,12 @@ pre-everything::
@${ECHO_MSG} "You can disable the CORE by defining WITHOUT_CORE."
.endif
-pre-configure:
- @cd ${WRKSRC}/config && ${AUTOCONF}
-
post-patch:
@${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
${WRKDIR}/wrapper.sh
+ @${REINPLACE_CMD} -E \
+ -e 's|%%AUTOCONF%%|${AUTOCONF}|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
do-install:
.ifndef(WITHOUT_CORE)