summaryrefslogtreecommitdiff
path: root/net-p2p/gtorrentviewer/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-10-26 18:03:43 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-10-26 18:03:43 +0000
commit80c62c16c1ab2af44139d656a0fb028eae1abbcd (patch)
treed96ddd862124b516951215f7c0fb373cf3d8b7a1 /net-p2p/gtorrentviewer/Makefile
parentUpdate to version 1.0 (diff)
Update to 0.2b.
Diffstat (limited to 'net-p2p/gtorrentviewer/Makefile')
-rw-r--r--net-p2p/gtorrentviewer/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net-p2p/gtorrentviewer/Makefile b/net-p2p/gtorrentviewer/Makefile
index ec30780bbf76..1af4012cc1cd 100644
--- a/net-p2p/gtorrentviewer/Makefile
+++ b/net-p2p/gtorrentviewer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtorrentviewer
-PORTVERSION= 0.2a
+PORTVERSION= 0.2b
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,22 +18,19 @@ COMMENT= GTK+2 viewer and editor for BitTorrent meta files
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
USE_GNOME= gtk20 gnomehier
+USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_GETOPT_LONG=yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-pixmapsdir=${PREFIX}/share/gnome/pixmaps \
+ --with-desktopdir=${PREFIX}/share/gnome/applications
MAN1= gtorrentviewer.1
DOCS= AUTHORS COPYING ChangeLog README
-post-patch:
- @${REINPLACE_CMD} -e 's|[(]datadir[)]/applications|(prefix)/share/gnome/applications|g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|[(]datadir[)]/pixmaps|(prefix)/share/gnome/pixmaps|g' \
- ${WRKSRC}/pixmaps/Makefile.in
- @${REINPLACE_CMD} -e 's|SYSTEM_PIXMAPS_DIR|PIXMAPS_DIR|g' \
- ${WRKSRC}/src/mainwindow.h
-
.ifndef (NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}