summaryrefslogtreecommitdiff
path: root/net-p2p/giftoxic/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-28 13:34:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-28 13:34:01 +0000
commitea244fe8ccee55b9aeae086d816ede5cd7f29879 (patch)
treec03cd40f55dac0ce0c6e9bb75faddd48c0eda3d2 /net-p2p/giftoxic/Makefile
parentGet sound working by ignoring errors from our dummy SOUND_MIXER_INFO ioctl. (diff)
Add giFToxic, a GTK2 GUI on top of giFT daemon.
PR: ports/60640 Submitted by: Joel Diaz <joeldiaz@bellsouth.net>
Diffstat (limited to 'net-p2p/giftoxic/Makefile')
-rw-r--r--net-p2p/giftoxic/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/giftoxic/Makefile b/net-p2p/giftoxic/Makefile
new file mode 100644
index 000000000000..e879e5906eee
--- /dev/null
+++ b/net-p2p/giftoxic/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: giFToxic
+# Date Created: 23 December 2003
+# Whom: Joel Diaz <joeldiaz@bellsouth.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFToxic
+PORTVERSION= 0.0.9
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= giftoxic
+
+MAINTAINER= joeldiaz@bellsouth.net
+COMMENT= GTK2 client for giFT
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+
+USE_X_PREFIX= yes
+USE_GETOPT_LONG= yes
+USE_GNOME= gtk20 gnomeprefix gnomehack
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-included-gettext
+
+.include <bsd.port.mk>