summaryrefslogtreecommitdiff
path: root/net-p2p/freenet05/files
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-31 11:14:19 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-31 11:14:19 +0000
commitd4530ab3b645105655cf11ef0bc87fe8a6540bc3 (patch)
tree5c40e6e43e7dca1884fa2a52ff7fe660ec79e2a6 /net-p2p/freenet05/files
parentFixed MASTER_SITE_SUBDIR. (diff)
o Update to <bsd.java.mk> standard 2.0
o Bump PORTREVISION due to jar location changes Prompted by: hq
Diffstat (limited to 'net-p2p/freenet05/files')
-rw-r--r--net-p2p/freenet05/files/wrapper.sh7
1 files changed, 2 insertions, 5 deletions
diff --git a/net-p2p/freenet05/files/wrapper.sh b/net-p2p/freenet05/files/wrapper.sh
index 8d57ff0b023a..4c6a41452484 100644
--- a/net-p2p/freenet05/files/wrapper.sh
+++ b/net-p2p/freenet05/files/wrapper.sh
@@ -9,7 +9,7 @@ PREFIX="%%PREFIX%%"
# java
JAVA_VERSION="%%JAVA_VERSION%%"
JAVAVM_CALL="%%JAVAVM%%"
-JAR_DIR="%%JAR_DIR%%"
+JAVAJARDIR="%%JAVAJARDIR%%"
JAR_FILES="%%JAR_FILES%%"
JAR_START="%%JAR_START%%"
# data
@@ -84,10 +84,7 @@ prepare_home_dir () {
# link the jar files
for jar in ${JAR_FILES}
do
- if [ ! -h ${HOME_DIR}/${jar} ]
- then
- ln -sf ${PREFIX}/${JAR_DIR}/${jar} ${HOME_DIR}/${jar}
- fi
+ ln -sf ${PREFIX}/${JAVAJARDIR}/${jar} ${HOME_DIR}/${jar}
done
}