summaryrefslogtreecommitdiff
path: root/net-p2p/edonkey-tool-hash/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-12-23 11:11:23 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-12-23 11:11:23 +0000
commit2a863ebab07fb61f634826a12ed7046b7a621fbd (patch)
tree407eeb980111d97908a5df5172e10749562890c0 /net-p2p/edonkey-tool-hash/Makefile
parentImprove man page documentation on memstest 'all' argument and add (diff)
o Update to 0.3.2: older distfile no longer fetchable
o Update informational files pkg-{comment,descr} with new data added after this project moved to MASTER_SITE_SOURCEFORGE Approved by: portmgr (self & no objections)
Diffstat (limited to 'net-p2p/edonkey-tool-hash/Makefile')
-rw-r--r--net-p2p/edonkey-tool-hash/Makefile29
1 files changed, 15 insertions, 14 deletions
diff --git a/net-p2p/edonkey-tool-hash/Makefile b/net-p2p/edonkey-tool-hash/Makefile
index 50271e166808..696cce6079ed 100644
--- a/net-p2p/edonkey-tool-hash/Makefile
+++ b/net-p2p/edonkey-tool-hash/Makefile
@@ -6,27 +6,28 @@
#
PORTNAME= edonkey
-PORTVERSION= 0.0.2
+PORTVERSION= 0.3.2
CATEGORIES= misc
-MASTER_SITES= http://users.aber.ac.uk/tpm01/ed2k_tools/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ed2k-tools
PKGNAMESUFFIX= -tool-hash
-DISTNAME= ed2k_hash-${PORTVERSION:S/^0.//}
+DISTNAME= ed2k_hash-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/ed2k_hash
-
-# I could have written a Makefile but I would rather
-# not waste inodes
-do-build:
- cd ${WRKSRC} && ${CC} -D__linux ${CFLAGS} ${LDFLAGS} -lmd \
- -I${LOCALBASE}/include -L${LOCALBASE}/lib -lgnugetopt \
- ed2k_hash.c -o ${PORTNAME}${PKGNAMESUFFIX}
+post-patch:
+# respect CFLAGS
+ @${REINPLACE_CMD} -E -e \
+ 's|-O2||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX} \
- ${PREFIX}/bin
+# uphold POLA, do not change binary name
+ @${INSTALL_PROGRAM} ${WRKSRC}/ed2k_hash/ed2k_hash \
+ ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
.include <bsd.port.mk>