summaryrefslogtreecommitdiff
path: root/net-p2p/edonkey-gui-gtk/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-06-17 04:15:27 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-06-17 04:15:27 +0000
commit8090b06fe6cdec127a04e87bfff04c21845b7cb5 (patch)
tree0efb865a684547ecba277455e4ee8b3b5dc46420 /net-p2p/edonkey-gui-gtk/Makefile
parento After being repo copied from edonkey-gui-gtk: (diff)
o After being repo copied to linux-edonkey-gui-gtk:
- Remove all Linux references since this is now a FreeBSD native binary port - House the binary under MASTER_SITE_LOCAL - Update to 0.2 alpha Build 2002061600 - Add PKGMESSAGE on the binary issue. Small excerpt of most relevant part: "Currently, this native version is restricted to the following FreeBSD platforms: - i386 FreeBSD 4.x-STABLE (post 4.6R Release); OSVERSION=450006"
Diffstat (limited to 'net-p2p/edonkey-gui-gtk/Makefile')
-rw-r--r--net-p2p/edonkey-gui-gtk/Makefile60
1 files changed, 35 insertions, 25 deletions
diff --git a/net-p2p/edonkey-gui-gtk/Makefile b/net-p2p/edonkey-gui-gtk/Makefile
index 558e9c75b2b0..0c35deb9bd96 100644
--- a/net-p2p/edonkey-gui-gtk/Makefile
+++ b/net-p2p/edonkey-gui-gtk/Makefile
@@ -6,48 +6,58 @@
#
PORTNAME= edonkey
-PORTVERSION= 0.2.0.a
-CATEGORIES= net linux
-MASTER_SITES= http://users.aber.ac.uk/tpm01/
+PORTVERSION= 0.2.0.a.2002061600
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= lioux
PKGNAMESUFFIX= -gui-gtk
-DISTNAME= linux_gui_alpha_unstable
-EXTRACT_SUFX=
+DISTFILES= ed2k_gui-${PORTVERSION}.freebsd-stable-i386.gz
+EXTRACT_ONLY=
MAINTAINER= lioux@FreeBSD.org
-RUN_DEPENDS= donkey:${PORTSDIR}/net/edonkey-core \
- ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+RUN_DEPENDS= donkey:${PORTSDIR}/net/edonkey-core
ONLY_FOR_ARCHS= i386
-USE_LINUX= yes
-NO_WRKSUBDIR= yes
+XFREE86_VERSION= 4
+USE_GTK= yes
+USE_X_PREFIX= yes
NO_BUILD= yes
-STRIP=
+NO_WRKSUBDIR= yes
-STRIP_CMD= ${LINUXBASE}/usr/bin/strip
+BINARY_NAME= ed2k_gui
+DOC_FILES= faq.html faq_german.html
-.if exists(/usr/bin/brandelf)
-BRANDELF?= /usr/bin/brandelf
-.else
-BRANDELF?= brandelf
+.ifndef(NOPORTDOCS)
+DISTFILES+= ed2k_gui-${PORTVERSION}.doc.tar.gz
.endif
-BINARY_NAME= ed2k_gui
-
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
- @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${BINARY_NAME}
+post-extract:
+.ifndef(NOPORTDOCS)
+ @cd ${WRKSRC} && ${TAR} xzf \
+ ${DISTDIR}/ed2k_gui-${PORTVERSION}.doc.tar.gz
+.endif
+ @${GZCAT} ${DISTDIR}/ed2k_gui-${PORTVERSION}.freebsd-stable-i386.gz \
+ > ${WRKSRC}/${BINARY_NAME}
do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} \
+ ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+.endfor
+.endif
@${INSTALL_PROGRAM} ${WRKSRC}/${BINARY_NAME} ${PREFIX}/bin
+ @${LN} -s ${BINARY_NAME} ${PREFIX}/bin/edonkey-gui-gtk
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
-pre-install:
-.if exists(${STRIP_CMD})
- @${STRIP_CMD} ${WRKSRC}/${BINARY_NAME}
+.if ${OSVERSION} < 450006 || ${OSVERSION} >= 500000
+BROKEN= only available for 4.X-STABLE (post 4.6 Release)
.endif
- @${BRANDELF} -t Linux ${WRKSRC}/${BINARY_NAME}
.include <bsd.port.post.mk>