summaryrefslogtreecommitdiff
path: root/net-p2p/dctc/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-22 04:32:47 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-22 04:32:47 +0000
commitbc737cecdd7ad5ff3befcdfd212cb0b75e053b39 (patch)
treefe6f1621519189af72f850d91026b25f938553e1 /net-p2p/dctc/Makefile
parentAllow for slave ports to set different categories. (diff)
o New port dctc version 0.59: A DirectConnect (www.neo-modus.com)
text client for file sharing o Renamed hublist to dc_hublist; former was too generic o FreeBSD's send(2) (in fact, all *BSD) does not support MSG_NOSIGMASK or any similar feature. Therefore, tried to mimick it with signal masking. However, this introduces a possible race condition which, fortunaly, is not triggered by this application since it is not concurrent. Reviewed by: Anders Nor Berle <debolaz@debolaz.com>
Diffstat (limited to 'net-p2p/dctc/Makefile')
-rw-r--r--net-p2p/dctc/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/dctc/Makefile b/net-p2p/dctc/Makefile
new file mode 100644
index 000000000000..03e3ae25e460
--- /dev/null
+++ b/net-p2p/dctc/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: Direct Connect Text Client
+# Date created: Thu Nov 22 00:19:27 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dctc
+PORTVERSION= 0.59
+CATEGORIES= net
+MASTER_SITES= http://ac2i.tzo.com/dctc/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_GLIB= yes
+NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
+ALL_TARGET=
+
+DOC_FILES= COPYING ChangeLog INSTALL README \
+ Documentation/DCextension Documentation/commands \
+ Documentation/output Documentation/programs
+PROGRAM_FILES= dc_hublist dctc
+
+post-patch:
+ @${PERL} -pi -e 's/(CK?\(std)(out\))/\1_\2/' ${BUILD_WRKSRC}/*
+
+do-configure:
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} depend
+
+do-install:
+.for file in ${PROGRAM_FILES}
+ @${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>