summaryrefslogtreecommitdiff
path: root/net-p2p/dclib/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-07-16 00:37:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-07-16 00:37:16 +0000
commitb5a16bd3772e6b0ebfbf9fa8cdb907d383898297 (patch)
tree0f96578b0dcd7a8bb49ce7fc701764cf309ed71d /net-p2p/dclib/Makefile
parentUpdate to 0.58 (diff)
o New port dclib version 0.1 beta 9: Direct connect interface library
for dcgui o Assign maintainership to 1st submitter: Sverrir Valgeirsson <e96sv@yahoo.se> PR: 40419, 40585 Submitted by: Amar Takhar <verm@drunkmonk.net>, Sverrir Valgeirsson <e96sv@yahoo.se>
Diffstat (limited to 'net-p2p/dclib/Makefile')
-rw-r--r--net-p2p/dclib/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
new file mode 100644
index 000000000000..d04ad0c28ffc
--- /dev/null
+++ b/net-p2p/dclib/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: dclib
+# Date created: Wed 10 Jul 2002
+# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
+# Amar Takhar <verm@drunkmonk.net> et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= dclib
+PORTVERSION= 0.1.9
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
+ http://download.berlios.de/dcgui/ \
+ ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
+ http://dc.ketelhot.de/files/dcgui/unstable/source/
+MASTER_SITE_SUBDIR= dc-gui
+DISTNAME= dclib-0.1beta9
+
+MAINTAINER= e96sv@yahoo.se
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-xml-prefix=${LOCALBASE}
+INSTALLS_SHLIB= yes
+
+post-patch:
+# fix libxml2 test
+ @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@; \
+ s@%%LOCALBASE%%@${LOCALBASE}@g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e "s@Lu@llu@g" ${WRKSRC}/dclib/cstring.cpp
+# malloc.h is deprecated in favor of stdlib.h
+ @${FIND} ${WRKSRC} -type f -name "*.cpp" -o -name "*.h" | \
+ ${XARGS} -n 10 ${REINPLACE_CMD} 's|malloc\.h|stdlib.h|'
+
+.include <bsd.port.mk>