summaryrefslogtreecommitdiff
path: root/net-p2p/dclib/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-09-06 05:41:35 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-09-06 05:41:35 +0000
commit37e893340e0ff84432695c001c955891191e436f (patch)
treef92b637f811e0d665a9d2532bf01d4e4f3772633 /net-p2p/dclib/Makefile
parentAdd p5-XML-RSS-Parser v0.21, A liberal parser for RSS Feeds. (diff)
- Update to version 0.2.18
- Fix security vulnerability - Give maintainership to Markus Brueffer <brueffer@phoenix-systems.de> PR: 56509 Submitted by: Markus Brueffer <brueffer@phoenix-systems.de> (maintainer timeout > 2 months)
Diffstat (limited to 'net-p2p/dclib/Makefile')
-rw-r--r--net-p2p/dclib/Makefile36
1 files changed, 10 insertions, 26 deletions
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
index b2d7d5df7ada..ed150acc3f9f 100644
--- a/net-p2p/dclib/Makefile
+++ b/net-p2p/dclib/Makefile
@@ -7,44 +7,28 @@
#
PORTNAME= dclib
-PORTVERSION= 0.1.11
+PORTVERSION= 0.2.18
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+MASTER_SITES= http://download.berlios.de/dcgui/ \
http://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
- http://download.berlios.de/dcgui/ \
- ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
- http://dc.ketelhot.de/files/dcgui/unstable/source/
-MASTER_SITE_SUBDIR= dc-gui
-DISTNAME= dclib-0.1beta11
+ ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/
-MAINTAINER= e96sv@yahoo.se
+MAINTAINER= brueffer@phoenix-systems.de
COMMENT= Direct connect interface library for dcgui
-FORBIDDEN= "security bug--see <URL:http://dc.ketelhot.de/news.php>"
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
xml2.5:${PORTSDIR}/textproc/libxml2
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-xml-prefix=${LOCALBASE}
-INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
-post-patch:
-# fix libxml2 test
-# and, do not add optimizations because it might break some ARCHs, e.g.,
-# alpha
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
- @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@; \
- s@-O2@@; \
- s@%%LOCALBASE%%@${LOCALBASE}@g' \
+post-patch:
+ @${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e "s@Lu@llu@g" \
- ${WRKSRC}/dclib/cstring.cpp \
- ${WRKSRC}/dclib/cquerymanager.cpp
-# malloc.h is deprecated in favor of stdlib.h
- @${FIND} ${WRKSRC} -type f -name "*.cpp" -o -name "*.h" | \
- ${XARGS} -n 10 ${REINPLACE_CMD} 's|malloc\.h|stdlib.h|'
.include <bsd.port.mk>