summaryrefslogtreecommitdiff
path: root/net-p2p/createtorrent/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-01-07 20:23:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-01-07 20:23:50 +0000
commit9a71827f91d1aa7d9194dbef9ff4fb604f4e8a92 (patch)
tree251aa1137be409a870506181a29fcbf8105c9274 /net-p2p/createtorrent/Makefile
parent- Update to 0.9.0.1 (diff)
Add createtorrent 1.1.0, create BitTorrent files from the command line.
Diffstat (limited to 'net-p2p/createtorrent/Makefile')
-rw-r--r--net-p2p/createtorrent/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-p2p/createtorrent/Makefile b/net-p2p/createtorrent/Makefile
new file mode 100644
index 000000000000..87500d6fd33d
--- /dev/null
+++ b/net-p2p/createtorrent/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: createtorrent
+# Date created: 7 Jan 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= createtorrent
+PORTVERSION= 1.1.0
+CATEGORIES= net-p2p
+MASTER_SITES= http://www.createtorrent.com/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Create BitTorrent files from the command line
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+
+PLIST_FILES= bin/createtorrent
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>