summaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-06-06 01:10:34 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-06-06 01:10:34 +0000
commit5d8cd181d7e3480cf55fafee3310e2f37d9e97ca (patch)
tree6a7bbb3fa42785595b120126c59fe64e79a6be39 /net-mgmt
parentRepocopy from net-mgmt/cacti (r416066) -> net-mgmt/cacti88 (diff)
Repocopy from net-mgmt/cacti-spine (r419786) -> net-mgmt/cacti88-spine
Multithreaded poller for Cacti written in C New releases of Cacti are still unable to work with useful plugins like "GPS Map" and "Network Weathermap". PR: 219686 Submitted by: Vinicius Zavam <egypcio@googlemail.com> Approved by: garga (mentor) Differential Revision: https://reviews.freebsd.org/D11024
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/cacti-spine/Makefile2
-rw-r--r--net-mgmt/cacti88-spine/Makefile40
-rw-r--r--net-mgmt/cacti88-spine/distinfo3
-rw-r--r--net-mgmt/cacti88-spine/pkg-descr7
-rw-r--r--net-mgmt/cacti88-spine/pkg-plist2
6 files changed, 55 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 88ebb5e2bfeb..1623ee68effa 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -28,6 +28,7 @@
SUBDIR += cacti
SUBDIR += cacti-spine
SUBDIR += cacti88
+ SUBDIR += cacti88-spine
SUBDIR += ccnet-client
SUBDIR += ccnet-server
SUBDIR += cdpd
diff --git a/net-mgmt/cacti-spine/Makefile b/net-mgmt/cacti-spine/Makefile
index 6a8556fad4f1..ad96d1221033 100644
--- a/net-mgmt/cacti-spine/Makefile
+++ b/net-mgmt/cacti-spine/Makefile
@@ -22,6 +22,8 @@ CPPFLAGS+= `net-snmp-config --cflags`
LDFLAGS+= `net-snmp-config --libs`
USES= libtool mysql ssl
+CONFLICTS_INSTALL= cacti88
+
post-patch:
@${REINPLACE_CMD} 's,#define\ *DEFAULT_CONF_FILE .*,#define DEFAULT_CONF_FILE "${PREFIX}/etc/spine.conf",' ${WRKSRC}/spine.h
diff --git a/net-mgmt/cacti88-spine/Makefile b/net-mgmt/cacti88-spine/Makefile
new file mode 100644
index 000000000000..dae1b054d227
--- /dev/null
+++ b/net-mgmt/cacti88-spine/Makefile
@@ -0,0 +1,40 @@
+# Created by: clement@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= spine
+PORTVERSION= 0.8.8h
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.cacti.net/downloads/${PORTNAME}/
+PKGNAMEPREFIX= cacti88-
+DISTNAME= cacti-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= egypcio@googlemail.com
+COMMENT= Multithreaded poller for Cacti written in C
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= help2man:misc/help2man
+LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp \
+ libpkg.so:ports-mgmt/pkg
+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} --with-snmp=${LOCALBASE}
+CPPFLAGS+= `net-snmp-config --cflags`
+LDFLAGS+= `net-snmp-config --libs`
+USES= libtool mysql ssl
+
+CONFLICTS_INSTALL= cacti spine
+
+PORTSCOUT= limit:^0.*
+
+post-patch:
+ @${REINPLACE_CMD} 's,#define\ *DEFAULT_CONF_FILE .*,#define DEFAULT_CONF_FILE "${PREFIX}/etc/spine.conf",' ${WRKSRC}/spine.h
+
+do-build:
+ @cd ${WRKSRC}; ${MAKE}
+
+post-install:
+ ${MV} ${STAGEDIR}${PREFIX}/etc/spine.conf.dist ${STAGEDIR}${PREFIX}/etc/spine.conf.sample
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/cacti88-spine/distinfo b/net-mgmt/cacti88-spine/distinfo
new file mode 100644
index 000000000000..81e346048f46
--- /dev/null
+++ b/net-mgmt/cacti88-spine/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470602099
+SHA256 (cacti-spine-0.8.8h.tar.gz) = a693136839bd7d03cae5b3ff4614a4d21a2153ffb14d09fc061b843ab0b2bb30
+SIZE (cacti-spine-0.8.8h.tar.gz) = 804951
diff --git a/net-mgmt/cacti88-spine/pkg-descr b/net-mgmt/cacti88-spine/pkg-descr
new file mode 100644
index 000000000000..161d137cf447
--- /dev/null
+++ b/net-mgmt/cacti88-spine/pkg-descr
@@ -0,0 +1,7 @@
+Spine, formerly Cactid, is a poller for Cacti that primarily strives to be as
+fast as possible. For this reason it is written in native C, makes use of POSIX
+threads, and is linked directly against the net-snmp library for minmumal SNMP
+polling overhead. Spine is a replacement for the default cmd.php poller so you
+must decide if using Spine makes sense for your installation.
+
+WWW: http://cacti.net/spine_info.php
diff --git a/net-mgmt/cacti88-spine/pkg-plist b/net-mgmt/cacti88-spine/pkg-plist
new file mode 100644
index 000000000000..152c17fb2b6a
--- /dev/null
+++ b/net-mgmt/cacti88-spine/pkg-plist
@@ -0,0 +1,2 @@
+bin/spine
+@sample etc/spine.conf.sample