summaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2004-01-03 03:18:29 +0000
committerBruce M Simpson <bms@FreeBSD.org>2004-01-03 03:18:29 +0000
commite39c2d565646218fd895ccdf93def06cbc89f3ed (patch)
tree7de446e8c3b0cbb227be675c51d2b865548f9e7d /net-mgmt/net-snmp/Makefile
parentUpdate to 2.0.7. (diff)
Add an extra flag, WITH_INETADDRESS_HACK. Enabling this flag for build will
cause InetAddress and InetAddressType OIDs to be handled specially during presentation. Normally they are simply displayed as hex due to being octet-strings, but this is not how they are intended to be presented. This allows IPv6 addresses to be presented correctly, as well as IPv4 in emerging and existing MIBs which use the new InetAddress type. Reviewed by: kuriyama, fenner Tested with: snmpwalk, mbrowse
Diffstat (limited to 'net-mgmt/net-snmp/Makefile')
-rw-r--r--net-mgmt/net-snmp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 0afbfb88bb87..c124f384de6a 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -113,6 +113,10 @@ SHLIB_VERSION= 6
PLIST_SUB+= shlib=${SHLIB_VERSION}
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+.if defined(WITH_INETADDRESS_HACK)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-snmplib::mib.c
+.endif
+
post-patch:
@${REINPLACE_CMD} \
-e 's|%%LTCONFIG%%|${LIBTOOL_SHAREDIR}/ltconfig${LIBTOOL_VERSION}|g' \