summaryrefslogtreecommitdiff
path: root/net-mgmt/mbrowse
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-08 09:30:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-08 09:30:28 +0000
commitc0fde423170dd5b7283b28252f035ba7b125ca4a (patch)
tree605717dd81817fb343270facce35ef40edfac744 /net-mgmt/mbrowse
parentPlay nice with new GCC, and unbreak the build. (diff)
Unbreak the build by making GCC feel better.
Reported by: kris Approved by: portmgr (krion), fjoe (mentor, implicit)
Diffstat (limited to 'net-mgmt/mbrowse')
-rw-r--r--net-mgmt/mbrowse/Makefile8
-rw-r--r--net-mgmt/mbrowse/files/patch-src+snmpstuff.c11
2 files changed, 12 insertions, 7 deletions
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index e31696929beb..c77e12e9e81d 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -33,10 +33,4 @@ CONFIGURE_ENV+= LDFLAGS="`net-snmp-config --libs`" \
CONFIGURE_ARGS+= --with-snmp-type=net
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/mbrowse/files/patch-src+snmpstuff.c b/net-mgmt/mbrowse/files/patch-src+snmpstuff.c
new file mode 100644
index 000000000000..fcc675af530f
--- /dev/null
+++ b/net-mgmt/mbrowse/files/patch-src+snmpstuff.c
@@ -0,0 +1,11 @@
+--- src/snmpstuff.c.orig Fri Oct 8 14:07:16 2004
++++ src/snmpstuff.c Fri Oct 8 14:08:08 2004
+@@ -359,7 +359,7 @@
+ case TYPE_NSAPADDRESS:
+ case TYPE_NETADDR:
+ case TYPE_OTHER:
+- default:
++ default: ;
+ }
+ }
+ if (type == 0) {