summaryrefslogtreecommitdiff
path: root/net-mgmt/annextools/files/patch-na::Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2003-09-25 19:49:31 +0000
committerBruce M Simpson <bms@FreeBSD.org>2003-09-25 19:49:31 +0000
commit94886678c1e033de12c9ac018e86e46929243712 (patch)
treef7e9eec06f45c11741b9d260056f6d21729d7894 /net-mgmt/annextools/files/patch-na::Makefile
parent- Update to version 2.1.10 (diff)
Add the Xylogics/Bay Networks/Nortel Networks Annex administration suite.
Allows the Annex to be administered from a FreeBSD host, rather than via the console port. Tested with a MicroAnnex-XL 16 port device. Reviewed by: edwin Approved by: jake (mentor)
Diffstat (limited to 'net-mgmt/annextools/files/patch-na::Makefile')
-rw-r--r--net-mgmt/annextools/files/patch-na::Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-mgmt/annextools/files/patch-na::Makefile b/net-mgmt/annextools/files/patch-na::Makefile
new file mode 100644
index 000000000000..9812f8f692f3
--- /dev/null
+++ b/net-mgmt/annextools/files/patch-na::Makefile
@@ -0,0 +1,20 @@
+--- na/Makefile.orig Mon Jun 3 15:45:07 1996
++++ na/Makefile Thu Sep 18 20:10:32 2003
+@@ -50,7 +50,7 @@
+
+ OFILES = main.o cmd.o parse.o do.o sub.o conv.o conv2.o pager.o
+ CFILES = main.c cmd.c parse.c do.c sub.c conv.c conv2.c pager.c
+-AFILES = ../netadm/netadm.a ../libannex/libannex.a
++AFILES = ../libannex/libannex.a ../netadm/netadm.a
+ EFILES = na
+
+ all:
+@@ -72,7 +72,7 @@
+ ${RM} -f ${OFILES} ${EFILES}
+
+ na: ${OFILES} ${AFILES}
+- ${CC} ${NACFLAGS} -o na ${OFILES} ${AFILES} ${LIBFLAG}
++ ${CC} ${NACFLAGS} -o na ${OFILES} -L../libannex -L../netadm -lnetadm -lannex
+
+ ../libannex/libannex.a:
+ cd ../libannex; $(MAKE)