summaryrefslogtreecommitdiff
path: root/net-im/p5-Jabber-Connection/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-02 07:14:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-02 07:14:17 +0000
commitc3d050563b3af33b389363cb2fdc5feabf953f0f (patch)
tree7d29b7479ec660943c91417173ff6f77f94eeed8 /net-im/p5-Jabber-Connection/Makefile
parentTake maintainership. (diff)
Add p5-Jabber-Connection 0.04, jabber Perl library for
client/component connectivity. PR: 57478 Submitted by: Lars Eggert
Diffstat (limited to 'net-im/p5-Jabber-Connection/Makefile')
-rw-r--r--net-im/p5-Jabber-Connection/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-im/p5-Jabber-Connection/Makefile b/net-im/p5-Jabber-Connection/Makefile
new file mode 100644
index 000000000000..46bbb62aee01
--- /dev/null
+++ b/net-im/p5-Jabber-Connection/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Jabber-Connection
+# Date created: 01 October 2003
+# Whom: Lars Eggert
+#
+# $FreeBSD$
+#
+
+PORTNAME= Jabber-Connection
+PORTVERSION= 0.04
+CATEGORIES= net perl5
+#MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+#MASTER_SITE_SUBDIR= Jabber
+MASTER_SITES= http://www.pipetree.com/jabber/jabberconnection/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= larse@isi.edu
+COMMENT= Jabber Perl library for client/component connectivity
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Jabber::Connection.3 Jabber::NS.3 Jabber::NodeFactory.3
+
+.include <bsd.port.mk>