summaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-23 21:59:42 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-23 21:59:42 +0000
commit65c0626261a052eec9a6e921538a5d64d6feefb5 (patch)
tree69bd54041265b1190ddbdc6d1d22c12871acf61d /multimedia
parent- Add PORTDOCS to pkg-plist (diff)
Use USE_SDL macros in these ports.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gopchop/Makefile5
-rw-r--r--multimedia/smpeg-xmms/Makefile2
-rw-r--r--multimedia/smpeg/Makefile2
-rw-r--r--multimedia/xmms-avi/Makefile2
-rw-r--r--multimedia/xmps/Makefile5
-rw-r--r--multimedia/xtheater/Makefile9
6 files changed, 9 insertions, 16 deletions
diff --git a/multimedia/gopchop/Makefile b/multimedia/gopchop/Makefile
index a62a12cec9b1..edbc88f646d5 100644
--- a/multimedia/gopchop/Makefile
+++ b/multimedia/gopchop/Makefile
@@ -19,13 +19,12 @@ COMMENT= MPEG2 GOP-accurate editor
LIB_DEPENDS= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
-USE_SDL= yes
+USE_SDL= sdl
USE_GETOPT_LONG= yes
USE_GNOME= gnometarget gtk12
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- SDLCONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-mlib
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
diff --git a/multimedia/smpeg-xmms/Makefile b/multimedia/smpeg-xmms/Makefile
index 1409973b58fe..2669b8b46741 100644
--- a/multimedia/smpeg-xmms/Makefile
+++ b/multimedia/smpeg-xmms/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= smpeg.1:${PORTSDIR}/multimedia/smpeg \
xmms.4:${PORTSDIR}/multimedia/xmms
USE_X_PREFIX= yes
-USE_SDL= yes
+USE_SDL= sdl
USE_GNOME= gnomehack gtk12
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/multimedia/smpeg/Makefile b/multimedia/smpeg/Makefile
index de426c9c9aeb..0428c52b79ea 100644
--- a/multimedia/smpeg/Makefile
+++ b/multimedia/smpeg/Makefile
@@ -22,7 +22,7 @@ WANT_GNOME= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_SDL= yes
+USE_SDL= sdl
INSTALLS_SHLIB= yes
CONFIGURE_ENV= GLBASE="${X11BASE}" \
CPPFLAGS="-I${X11BASE}/include" \
diff --git a/multimedia/xmms-avi/Makefile b/multimedia/xmms-avi/Makefile
index 196a3e65d2a2..44a1436a1e0b 100644
--- a/multimedia/xmms-avi/Makefile
+++ b/multimedia/xmms-avi/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
ONLY_FOR_ARCHS= i386
USE_X_PREFIX= yes
-USE_SDL= yes
+USE_SDL= sdl
USE_GNOME= gtk12
USE_REINPLACE= yes
GNU_CONFIGURE= yes
diff --git a/multimedia/xmps/Makefile b/multimedia/xmps/Makefile
index c5d41c31c6a2..c4c5d7253881 100644
--- a/multimedia/xmps/Makefile
+++ b/multimedia/xmps/Makefile
@@ -15,17 +15,14 @@ MASTER_SITES= # http://xmps.sourceforge.net/sources/
MAINTAINER= ports@FreeBSD.org
COMMENT= X MPEG Player System - a media player with a very nice GUI
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_SDL= sdl
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs gdkpixbuf
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- SDL_CONFIG="${SDL_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
diff --git a/multimedia/xtheater/Makefile b/multimedia/xtheater/Makefile
index b065b5ae82fb..5d219c0d5e86 100644
--- a/multimedia/xtheater/Makefile
+++ b/multimedia/xtheater/Makefile
@@ -17,19 +17,16 @@ DISTNAME= Xtheater-${PORTVERSION:S/.p/-pre/}
MAINTAINER= ports@FreeBSD.org
COMMENT= MPEG-1 player in GTK+ capable of playing MPEG-1 format streams
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- smpeg.1:${PORTSDIR}/multimedia/smpeg
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+LIB_DEPENDS= smpeg.1:${PORTSDIR}/multimedia/smpeg
+USE_SDL= sdl
USE_BZIP2= yes
USE_GNOME= gtk12
USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-gl
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}