summaryrefslogtreecommitdiff
path: root/multimedia/xine
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 21:36:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 21:36:39 +0000
commitd203b12054ad82d30bac1f0a0c022b1393f861b3 (patch)
treeaa853b3ada1746f7fe92c44b10a0a57900e6b933 /multimedia/xine
parentConfigure --without-capi --without-gphoto and --without-sane to avoid (diff)
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'multimedia/xine')
-rw-r--r--multimedia/xine/Makefile21
-rw-r--r--multimedia/xine/files/extra-patch-src:xitk:common.h11
-rw-r--r--multimedia/xine/files/extra-patch-src:xitk:common.h-115
3 files changed, 0 insertions, 47 deletions
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index 96fe84e8a0a8..8533a02c21e8 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -52,27 +52,6 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif
.endif
-.if ${OSVERSION} == 500043
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src:xitk:common.h
-.endif
-
-# PRIi64 macro is not defined
-.if ${OSVERSION} < 500040
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src:xitk:common.h-1
-.endif
-
-# mbrtowc() is not implemented
-.if ${OSVERSION} < 500039
-CONFIGURE_ARGS+= --disable-mbs
-# Xft support requires --enable-mbs configure option
-WITHOUT_XFT= yes
-.endif
-
-.if ${OSVERSION} < 502000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
-.endif
-
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
diff --git a/multimedia/xine/files/extra-patch-src:xitk:common.h b/multimedia/xine/files/extra-patch-src:xitk:common.h
deleted file mode 100644
index 55a644b31ff2..000000000000
--- a/multimedia/xine/files/extra-patch-src:xitk:common.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xitk/common.h.orig Mon Feb 24 22:39:16 2003
-+++ src/xitk/common.h Mon Feb 24 22:39:46 2003
-@@ -31,6 +31,8 @@
- #include <xine.h>
- #include <xine/xineutils.h>
-
-+#define ushort unsigned short
-+
- #include "Imlib-light/Imlib.h"
-
- #include "xitk.h"
diff --git a/multimedia/xine/files/extra-patch-src:xitk:common.h-1 b/multimedia/xine/files/extra-patch-src:xitk:common.h-1
deleted file mode 100644
index 1b56caf35979..000000000000
--- a/multimedia/xine/files/extra-patch-src:xitk:common.h-1
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/xitk/common.h.orig Fri Apr 16 04:20:51 2004
-+++ src/xitk/common.h Wed May 12 23:17:59 2004
-@@ -114,6 +114,12 @@
- #define PLAYLIST_CONTROL_STOP 0x00000001 /* Don't start next entry in playlist */
- #define PLAYLIST_CONTROL_IGNORE 0x00000002 /* Ignore some playlist adding action */
-
-+#if defined(__alpha__) || defined(__amd64__) || defined(__ia64__) || defined(__sparc64__)
-+#define PRIi64 "li"
-+#else if defined(__i386__) || defined(__powerpc__)
-+#define PRIi64 "lli"
-+#endif
-+
- #define SAFE_FREE(x) do { \
- if((x)) { \
- free((x)); \