summaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
commit93872f18cc0a948ab9c010bbe5694579bd59f8c4 (patch)
tree918c0e1660ed837a4087b57670a1b1c181c285e0 /misc
parentRemove some local changes that crept in with the previous commit. (diff)
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'misc')
-rw-r--r--misc/afbackup/Makefile12
-rw-r--r--misc/estic/Makefile12
-rw-r--r--misc/menushki/Makefile12
-rw-r--r--misc/vbidecode/Makefile4
4 files changed, 20 insertions, 20 deletions
diff --git a/misc/afbackup/Makefile b/misc/afbackup/Makefile
index 6e1605c92aa1..f7d438ad788a 100644
--- a/misc/afbackup/Makefile
+++ b/misc/afbackup/Makefile
@@ -22,12 +22,6 @@ WRKSRC= ${WRKDIR}/afbackup-3.3.5
PLIST= ${WRKSRC}/pkg-plist
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
.if ! defined(NO_DES)
USE_OPENSSL= yes
CONFIG_WITH_DES= --with-des --with-des-header=openssl/des.h \
@@ -139,6 +133,12 @@ PKGINSTALL_ENV= "NONINTERACTIVE=YES"
PKGINSTALL_ENV=
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
.if !defined(WITHOUT_SERVER) && !defined(WITHOUT_CLIENT) \
&& !defined(WITHOUT_REXECLINKS) && !defined(NO_GUI) \
&& !defined(NO_DES) && !defined(NO_AUTOKEY)
diff --git a/misc/estic/Makefile b/misc/estic/Makefile
index 03f601d9d3d6..bb5ca87a27fc 100644
--- a/misc/estic/Makefile
+++ b/misc/estic/Makefile
@@ -14,12 +14,6 @@ DISTNAME= estic-${PORTVERSION}-sources
MAINTAINER= jhs@FreeBSD.org
COMMENT= Controller for ISDN TK-Anlage (PBX) made by Istec
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_XLIB= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
@@ -38,6 +32,12 @@ PBX_DOC=${PREFIX}/share/doc/estic
ESTIC=${WRKSRC}/estic
MAKE_E= make X11BASE=${X11BASE} -f make/freebsd${X_OR_NOT}.mak
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-configure:
@cd ${WRKSRC}/spunk ; ${MAKE_E} dep
@cd ${ESTIC} ; ${MAKE_E} dep
diff --git a/misc/menushki/Makefile b/misc/menushki/Makefile
index d25138659393..7f864bcfb858 100644
--- a/misc/menushki/Makefile
+++ b/misc/menushki/Makefile
@@ -14,18 +14,18 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@FreeBSD.org
COMMENT= Menu converter between varieties of Window Managers
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
DOCS= AUTHORS ChangeLog README TODO
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/misc/vbidecode/Makefile b/misc/vbidecode/Makefile
index fc3b7411a94b..e6ad695cc19b 100644
--- a/misc/vbidecode/Makefile
+++ b/misc/vbidecode/Makefile
@@ -17,14 +17,14 @@ DISTNAME= bttv-0.6.4
MAINTAINER= roger@freebsd.org
COMMENT= Get Videotext/Teletext (.vtx) and other VBI data from TV channels
+WRKSRC= ${WRKDIR}/bttv/apps/vbidecode
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-WRKSRC= ${WRKDIR}/bttv/apps/vbidecode
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vbidecode ${PREFIX}/bin
@strip ${PREFIX}/bin/vbidecode