summaryrefslogtreecommitdiff
path: root/misc/videotext/Makefile
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-08-16 20:49:59 +0000
committerSimon Barner <barner@FreeBSD.org>2005-08-16 20:49:59 +0000
commitf2db0bcd9543cb80c6da9bebfc7bdd5a6316d432 (patch)
tree041e3203742321dd481435694bd5967559df7182 /misc/videotext/Makefile
parentFix security issue noted in http://drupal.org/files/sa-2005-004/advisory.txt. (diff)
- Fix build with new gcc version (patch-tvchannels.c)
- Remove s/gawk/awk/ patches and introduce build time dependecy to gawk because one of the scripts uses `strftime' which is not available in our base systems awk. Approved by: portmgr (clement)
Diffstat (limited to 'misc/videotext/Makefile')
-rw-r--r--misc/videotext/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/misc/videotext/Makefile b/misc/videotext/Makefile
index 63a01e4758d7..015e3ac836e3 100644
--- a/misc/videotext/Makefile
+++ b/misc/videotext/Makefile
@@ -14,7 +14,9 @@ MASTER_SITES= http://elektra.e-technik.uni-ulm.de/~mbuck/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= X11/Xview TV Videotext/Teletext page viewer (.vtx files)
-BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
+BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT} \
+ gawk:${PORTSDIR}/lang/gawk
+
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
xview.3:${PORTSDIR}/x11-toolkits/xview
@@ -25,10 +27,4 @@ MAN1= tunerctl.1 videotext.1 vtxget.1
FONTSDIR= lib/X11/fonts/local
PLIST_SUB= FONTSDIR=${FONTSDIR}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502102
-BROKEN= "Does not build"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>