summaryrefslogtreecommitdiff
path: root/misc/tkman/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-21 12:02:17 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-21 12:02:17 +0000
commitadeb7ff8955ba9665ba530405657c39a9514f9c4 (patch)
tree86e093738357cbe18f17c07d3914936f1d0d254c /misc/tkman/Makefile
parent- Update to 2.6.12 [2] (diff)
Use MAKE_ARGS
Diffstat (limited to 'misc/tkman/Makefile')
-rw-r--r--misc/tkman/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/misc/tkman/Makefile b/misc/tkman/Makefile
index 8941ef9d451a..b3128d396be7 100644
--- a/misc/tkman/Makefile
+++ b/misc/tkman/Makefile
@@ -20,12 +20,24 @@ RUN_DEPENDS= rman:${PORTSDIR}/textproc/rman \
glimpse:${PORTSDIR}/textproc/glimpse
USE_GMAKE= yes
+MAKE_ARGS= WISH="${PREFIX}/bin/wish8.4" \
+ texinfodir="${PREFIX}/info" \
+ gzgrep="\"/usr/bin/zgrep -E\"" \
+ mastermen="\"/usr/share/man ${PREFIX}/man ${X11BASE}/man\"" \
+ masterbin="\"/usr/bin ${PREFIX}/bin ${X11BASE}/bin\"" \
+ manformat="{groff -Tlatin1 -te -mandoc}" \
+ manprint="{groff -mandoc -Tps -te -l}"
+
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e "s;/usr/local/bin/wish;${PREFIX}/bin/wish8.4;" \
${WRKSRC}/contrib/tkmanclient
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkman ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/retkman ${PREFIX}/bin
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}