summaryrefslogtreecommitdiff
path: root/misc/p5-Business-OnlinePayment-2CheckOut/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-10-25 08:44:15 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-10-25 08:44:15 +0000
commit0c20db3751c6ece85af63395722334ad811f51f0 (patch)
tree17e54cdb914940c3adc58b8dc4d7ae439abb8e8e /misc/p5-Business-OnlinePayment-2CheckOut/Makefile
parentMade games/xlifegame buildable under -current again (diff)
Add p5-Business-OnlinePayment-2CheckOut 0.02, a Business::OnlinePayment
backend module for 2CheckOut authorization service.
Diffstat (limited to 'misc/p5-Business-OnlinePayment-2CheckOut/Makefile')
-rw-r--r--misc/p5-Business-OnlinePayment-2CheckOut/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/p5-Business-OnlinePayment-2CheckOut/Makefile b/misc/p5-Business-OnlinePayment-2CheckOut/Makefile
new file mode 100644
index 000000000000..3e0ddd7dcc0e
--- /dev/null
+++ b/misc/p5-Business-OnlinePayment-2CheckOut/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Business::OnlinePayment::2CheckOut
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OnlinePayment-2CheckOut
+PORTVERSION= 0.02
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/misc/p5-Business-CreditCard \
+ ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/misc/p5-Business-OnlinePayment \
+ ${SITE_PERL}/${PERL_ARCH}/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Business::OnlinePayment::2CheckOut.3
+
+.include <bsd.port.mk>