summaryrefslogtreecommitdiff
path: root/misc/mshell/Makefile
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-09-24 03:57:13 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-09-24 03:57:13 +0000
commit7883df5ea28a0934e59540ca93a33a726bb9aa07 (patch)
tree394ed05dcd53aebfd6c2d7e23c5b011aee6a4eab /misc/mshell/Makefile
parentUpdate this to fix install problem. (diff)
Mshell port from Jean-Marc Zucconi (jmz@thud.cdrom.com). Jean-Marc
is now our leading ports-supplier! Let's all give him a big THANK YOU! :) Submitted by: jmz
Diffstat (limited to 'misc/mshell/Makefile')
-rw-r--r--misc/mshell/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/misc/mshell/Makefile b/misc/mshell/Makefile
new file mode 100644
index 000000000000..0880f95790aa
--- /dev/null
+++ b/misc/mshell/Makefile
@@ -0,0 +1,18 @@
+DISTNAME= mshell
+DISTFILES= 7432.Z
+MASTER_SITES= ftp://src.doc.ic.ac.uk/usenet/alt.sources/articles/7000-7999/
+NO_WRKSUBDIR= yes
+
+EXTRACT_COOKIE?= ${.CURDIR}/.extract_done
+
+extract: fetch pre-extract ${EXTRACT_COOKIE}
+
+${EXTRACT_COOKIE}:
+ @echo "===> Extracting for ${DISTNAME}"
+ @rm -rf ${WRKDIR}
+ @mkdir -p ${WRKDIR}
+ zcat ${DISTDIR}/${DISTFILES} |(cd ${WRKDIR}; \
+ awk '{if (/^#!/) x++} {if(x) print $$0'}| /bin/sh)
+ @touch -f ${EXTRACT_COOKIE}
+
+.include <bsd.port.mk>