summaryrefslogtreecommitdiff
path: root/misc/moviedb/files
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-09-16 19:40:59 +0000
committerWill Andrews <will@FreeBSD.org>2000-09-16 19:40:59 +0000
commit384b39e0ed07a6f8046c4ea6ce18864bc47506ea (patch)
treef950cc4abe7da7cb7b5167ba78debdd449666cdf /misc/moviedb/files
parentUpdate to 1.4.2.4 (diff)
Add moviedb 3.8, the Internet Movie Database package. It contains various
tools to download, update, and search through the Database. PR: 20659 Submitted by: Kim Scarborough <sluggo@unknown.nu>
Diffstat (limited to 'misc/moviedb/files')
-rw-r--r--misc/moviedb/files/patch-aa76
-rw-r--r--misc/moviedb/files/patch-ab22
-rw-r--r--misc/moviedb/files/patch-ac28
-rw-r--r--misc/moviedb/files/patch-ad10
4 files changed, 136 insertions, 0 deletions
diff --git a/misc/moviedb/files/patch-aa b/misc/moviedb/files/patch-aa
new file mode 100644
index 000000000000..a0805fd9aa77
--- /dev/null
+++ b/misc/moviedb/files/patch-aa
@@ -0,0 +1,76 @@
+--- Makefile.orig Tue Oct 22 00:36:06 1996
++++ Makefile Tue Aug 15 08:54:20 2000
+@@ -118,13 +118,13 @@
+
+ ZLISTCOMPRESS = gzip
+ ZLISTEXT = .gz
+-ZLISTCAT = /usr/bin/gzip
+-ZLISTCATOPTS = -cd
++ZLISTCAT = /usr/bin/zcat
++ZLISTCATOPTS =
+
+ ZDBSCOMPRESS = gzip
+ ZDBSEXT = .gz
+-ZDBSCAT = /usr/bin/gzip
+-ZDBSCATOPTS = -cd
++ZDBSCAT = /usr/bin/zcat
++ZDBSCATOPTS =
+
+
+ # Set KEEPLIST to @true if you want to keep the lists.
+@@ -138,8 +138,7 @@
+ # Set AUTOUNCOMPRESS to nothing if you want to keep the source lists as
+ # compressed files (that is, as they come from the server). Setting it
+ # to nothing will reduce the extra space required during the install.
+-#AUTOUNCOMPRESS =
+-AUTOUNCOMPRESS = autouncompress
++AUTOUNCOMPRESS =
+
+ # Options for mkdb (for instance -m, -debug or -nochar)
+ # set to -nochar to ignore character names when processing the cast lists
+@@ -153,11 +152,11 @@
+
+ # Where will the databases be?
+ #DBDIR = ../dbs/
+-DBDIR = `pwd`/dbs/
++DBDIR = $(PREFIX)/lib/moviedb/
+
+ # Secondary files
+ #ETCDIR = ../etc/
+-ETCDIR = `pwd`/etc/
++ETCDIR = $(PREFIX)/libexec/moviedb/
+
+ # Source files
+ #SRCDIR = ../src/
+@@ -165,11 +164,11 @@
+
+ # Executable files
+ #BINDIR = ../bin/
+-BINDIR = `pwd`/bin/
++BINDIR = $(PREFIX)/bin/
+
+ # Top-level manpages directory (man1 should be a subdirectory of this)
+ #MANDIR = /usr/man/
+-MANDIR = `pwd`/man/
++MANDIR = $(PREFIX)/man/
+
+ # Main directory
+ #MAINDIR = ./
+@@ -235,7 +234,7 @@
+ # If the sanity check insists on telling you that ZLISTCAT, ZLISTCOMPRESS
+ # and so on are invalid, and you are definitively sure they are ok,
+ # set ZSANITYCHECK to the empty string.
+-ZSANITYCHECK = sanity-check-z
++ZSANITYCHECK =
+
+ # If you are using compressed database files, you have the tempnam() call
+ # and you want control over the directory where the files are uncompressed,
+@@ -286,7 +285,7 @@
+ do-installman
+
+ do-installman:
+- cd $(MANDIR); $(MAKE) MANDIR="$(MANDIR)" DBDIR="$(DBDIR)" \
++ cd `pwd`/man; $(MAKE) MANDIR="$(MANDIR)" DBDIR="$(DBDIR)" \
+ MAINDIR="$(MAINDIR)" \
+ RELEASEDATE="$(RELEASEDATE)" VERSIONNUMBER="$(VERSIONNUMBER)"\
+ installman
diff --git a/misc/moviedb/files/patch-ab b/misc/moviedb/files/patch-ab
new file mode 100644
index 000000000000..9a79d19b455c
--- /dev/null
+++ b/misc/moviedb/files/patch-ab
@@ -0,0 +1,22 @@
+--- etc/lfetch.orig Sun Mar 7 20:23:33 1999
++++ etc/lfetch Sun Aug 13 19:33:32 2000
+@@ -80,8 +80,8 @@
+ #
+ ftpcmd=ftp # ftp command (eg ftp, gate-ftp)
+ ftpopts="-i -n -v" # ftp options
+-ftphost=uiarchive.cso.uiuc.edu # ftp host
+-ftpdir=pub/info/imdb # lists directory on host
++ftphost=ftp.imdb.com # ftp host
++ftpdir=pub/interfaces # lists directory on host
+ ftpuser=anonymous # ftp userid
+ #
+ #-----------------------------------------------------------------------------
+@@ -91,7 +91,7 @@
+ # temporary files
+ if [ -z "$MOVIESTMPDIR" ]; then
+ if [ -z "$TMPDIR" ]; then
+- MOVIESTMPDIR="."
++ MOVIESTMPDIR="/tmp"
+ else
+ MOVIESTMPDIR="$TMPDIR"
+ fi
diff --git a/misc/moviedb/files/patch-ac b/misc/moviedb/files/patch-ac
new file mode 100644
index 000000000000..2344040f5916
--- /dev/null
+++ b/misc/moviedb/files/patch-ac
@@ -0,0 +1,28 @@
+--- src/moviedb.h.orig Mon Mar 8 14:01:42 1999
++++ src/moviedb.h Mon Aug 14 22:57:35 2000
+@@ -28,8 +28,8 @@
+ #define FSEP '|'
+ #define MAXZCATARGS 10
+ #define MAXLSEEN 65534
+-#define MAXTITLES 300000
+-#define MAXATTRS 100000
++#define MAXTITLES 600000
++#define MAXATTRS 200000
+ #define MAXFILMOGRAPHIES 1023
+ #define MAXWITHATTRS 4095
+ #define MAXTITLERESULTS 4095
+@@ -46,11 +46,11 @@
+ #define MAXBUSENTRIES 20000
+ #define MAXBIOENTRIES 150000
+ #define MAXMRRENTRIES 40000
+-#define MAXAKAENTRIES 100000
+-#define MAXNAKAENTRIES 50000
++#define MAXAKAENTRIES 200000
++#define MAXNAKAENTRIES 100000
+ #define MAXTITLEINFO 300000
+ #define MAXPOS 255
+-#define MAXLINKS 200000
++#define MAXLINKS 400000
+ #define MAXLINKSPERMOVIE 250
+
+ #ifndef DBDIR
diff --git a/misc/moviedb/files/patch-ad b/misc/moviedb/files/patch-ad
new file mode 100644
index 000000000000..8be0c473af2a
--- /dev/null
+++ b/misc/moviedb/files/patch-ad
@@ -0,0 +1,10 @@
+--- dbs/Makefile.orig Mon Mar 8 14:26:31 1999
++++ dbs/Makefile Tue Aug 15 01:25:10 2000
+@@ -328,6 +328,7 @@
+ -[ -s genres.data ] && $(ZDBSCOMPRESS) genres.data
+ -[ -s keywords.data ] && $(ZDBSCOMPRESS) keywords.data
+ -[ -s goofs.data ] && $(ZDBSCOMPRESS) goofs.data
++ -[ -s language.data ] && $(ZDBSCOMPRESS) language.data
+ -[ -s laserdisc.data ] && $(ZDBSCOMPRESS) laserdisc.data
+ -[ -s literature.data ] && $(ZDBSCOMPRESS) literature.data
+ -[ -s locations.data ] && $(ZDBSCOMPRESS) locations.data