summaryrefslogtreecommitdiff
path: root/misc/mc/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2002-08-11 12:36:24 +0000
committerMax Khon <fjoe@FreeBSD.org>2002-08-11 12:36:24 +0000
commit948d071f34a66e518337348c89bb77b4aa12a6c8 (patch)
tree78cb9b16ea0dda4f4667920cb826c630d8757678 /misc/mc/Makefile
parent- add hooks and patches that add an ability to use this port as master (diff)
More changes to allow this port to be used as master for ports/x11-fm/gnomemc
Diffstat (limited to 'misc/mc/Makefile')
-rw-r--r--misc/mc/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 52eb658ae16c..3e482d8d72c4 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -45,22 +45,26 @@ PLIST_SUB= CHARSETS="@comment "
.endif
.if ${PORTNAME} == "mc"
CONFIGURE_ARGS+=--without-gnome
+.else
+CONFIGURE_ARGS+=--without-edit
.endif
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.if ${PORTNAME} == "mc"
-PLIST_SUB+= GNOMEMC="@comment " SHARE_PATH="share"
+PLIST_SUB+= GNOMEMC="@comment " MC="" SHARE_PATH="share"
+MAN1= mc.1 mcedit.1
.else
-PLIST_SUB+= GNOMEMC="" SHARE_PATH="share/gnome"
+PLIST_SUB+= GNOMEMC="" MC="@comment " SHARE_PATH="share/gnome"
.endif
-MAN1= mc.1 mcedit.1
-
post-patch:
@find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} \
-e 's|\$$(libdir)/mc|\$$(datadir)/mc|g' \
-e 's|\$$(datadir)/locale|\$$(prefix)/share/locale|g'
+.if ${PORTNAME} != "mc
+ @${REINPLACE_CMD} -e 's|^SUBDIRS = intl po vfs edit src lib doc|SUBDIRS = intl po vfs lib|' ${WRKSRC}/Makefile.in
+.endif
@${REINPLACE_CMD} -e 's|DRAR=/usr/bin|DRAR=${LOCALBASE}/bin|' \
${WRKSRC}/vfs/extfs/urar.in
@${REINPLACE_CMD} -e 's|/usr/bin/\(.*\)zip|${LOCALBASE}/bin/\1zip|' \