summaryrefslogtreecommitdiff
path: root/misc/gwhich/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-09-30 00:27:54 +0000
committerWill Andrews <will@FreeBSD.org>2000-09-30 00:27:54 +0000
commit037937fb7bb7f3de26eae1b97877bee5aaac12a2 (patch)
treec4f1356a8b589d4d47715bd154e006771773afa8 /misc/gwhich/Makefile
parent- Fix man.cgi (diff)
Add gwhich 2.12, which is GNU which(1). See pkg/DESCR for differences
between this and 1.0 of Paul Vixie's. PR: 21431 Submitted by: Jeremy Shaffner <jeremy@external.org>
Diffstat (limited to 'misc/gwhich/Makefile')
-rw-r--r--misc/gwhich/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/gwhich/Makefile b/misc/gwhich/Makefile
new file mode 100644
index 000000000000..2b72c0d4ae3a
--- /dev/null
+++ b/misc/gwhich/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gwhich
+# Date created: 20 September 2000
+# Whom: Jeremy Shaffner <jeremy@external.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwhich
+PORTVERSION= 2.12
+CATEGORIES= misc
+MASTER_SITES= http://www.xs4all.nl/~carlo17/which/
+DISTNAME= which-${PORTVERSION}
+
+MAINTAINER= jeremy@external.org
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=g
+
+MAN1= gwhich.1
+
+post-install:
+ @install-info ${PREFIX}/info/which.info ${PREFIX}/info/dir
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/examples/gwhich
+ @${INSTALL_DATA} ${WRKSRC}/EXAMPLES ${PREFIX}/share/examples/gwhich/EXAMPLES
+.else
+ @${SED} 's#share/examples/gwhich/EXAMPLES##' ${TMPPLIST} > ${WRKDIR}/PLIST.tmp
+ @${SED} 's#@dirrm share/examples/gwhich##' ${WRKDIR}/PLIST.tmp > ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>