summaryrefslogtreecommitdiff
path: root/misc/gretl/files
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-21 02:37:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-21 02:37:33 +0000
commit55903ecd9ec4544dcb02b09b46dd83a3e35808cd (patch)
treed76b9ec39c9b7b0d491cda1739f13230ac8303b2 /misc/gretl/files
parentThe ntp port now tracks the production branch, currently at 4.1.1a. (diff)
upgrade to 0.994
unbreak PR: 37687 Submitted by: Ports Fury
Diffstat (limited to 'misc/gretl/files')
-rw-r--r--misc/gretl/files/patch-Makefile.in14
-rw-r--r--misc/gretl/files/patch-configure10
-rw-r--r--misc/gretl/files/patch-gui::Makefile.in38
-rw-r--r--misc/gretl/files/patch-lib::Makefile.in40
-rw-r--r--misc/gretl/files/patch-plugin::Makefile.in51
-rw-r--r--misc/gretl/files/patch-plugin::workbook.c10
-rw-r--r--misc/gretl/files/patch-share::Makefile.in16
7 files changed, 179 insertions, 0 deletions
diff --git a/misc/gretl/files/patch-Makefile.in b/misc/gretl/files/patch-Makefile.in
new file mode 100644
index 000000000000..18ccc2247eff
--- /dev/null
+++ b/misc/gretl/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig Tue Mar 12 02:54:07 2002
++++ Makefile.in Thu May 2 01:42:34 2002
+@@ -22,8 +22,9 @@
+ CC = gcc
+ endif
+
+-INSTALL_PROGRAM = ${INSTALL} -m 755
+-INSTALL_DATA = ${INSTALL} -m 644
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
++INSTALL_DATA = @INSTALL_DATA@
+
+ export
+
diff --git a/misc/gretl/files/patch-configure b/misc/gretl/files/patch-configure
new file mode 100644
index 000000000000..4b01c0577cb3
--- /dev/null
+++ b/misc/gretl/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sun Apr 21 23:11:36 2002
++++ configure Wed May 1 06:58:01 2002
+@@ -6114,6 +6114,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/misc/gretl/files/patch-gui::Makefile.in b/misc/gretl/files/patch-gui::Makefile.in
new file mode 100644
index 000000000000..05a2282e2353
--- /dev/null
+++ b/misc/gretl/files/patch-gui::Makefile.in
@@ -0,0 +1,38 @@
+--- gui/Makefile.in.orig Mon Apr 22 01:43:31 2002
++++ gui/Makefile.in Thu May 2 01:49:12 2002
+@@ -41,21 +41,20 @@
+ LIBS = `gnome-config --libs gnomeui print` `gtkextra-config --libs` ../lib/libgretl.la
+ GUI_CFLAGS = `gnome-config --cflags gnomeui print` `gtkextra-config --cflags`
+ desktopdir = $(gnome_prefix)/share/gnome/apps/Applications
+- mimedir = $(gnome_prefix)/share/mime-info
+- gpixmaps = $(gnome_prefix)/share/pixmaps
++ mimedir = $(gnome_prefix)/share/gnome/mime-info
++ gpixmaps = $(gnome_prefix)/share/gnome/pixmaps
+ ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
+ query_install_gnome = install-gnome
+ else
+- LIBS = `gtk-config --libs` `gtkextra-config --libs` ../lib/libgretl.la
+- GUI_CFLAGS = `gtk-config --cflags` `gtkextra-config --cflags`
++ LIBS = `$(GTK_CONFIG) --libs` `gtkextra-config --libs` ../lib/libgretl.la
++ GUI_CFLAGS = `$(GTK_CONFIG) --cflags` `gtkextra-config --cflags`
+ endif
+
+ override CFLAGS += $(PIXBUF_CFLAGS)
+ override LIBS += $(PIXBUF_LIBS)
+
+ # Directories
+-bindir = $(prefix)/bin
+-gretldir = $(prefix)/share/gretl
++gretldir = $(libdir)/gretl
+ tooldir = $(topsrc)/tools
+ libsrc = $(topsrc)/lib/src
+ clisrc = $(topsrc)/cli
+@@ -90,7 +89,7 @@
+ $(LIBTOOL) $(INSTALL_PROGRAM) -s $(PROG) $(bindir)/$(PROG)
+
+ install-data: installdirs
+- $(INSTALL_PROGRAM) $(topsrc)/gretl_sh $(bindir)/gretl
++ $(INSTALL_SCRIPT) $(topsrc)/gretl_sh $(bindir)/gretl
+ $(INSTALL_DATA) gretl-logo.xpm $(gretldir)
+ $(INSTALL_DATA) $(topsrc)/COPYING $(gretldir)
+
diff --git a/misc/gretl/files/patch-lib::Makefile.in b/misc/gretl/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..b766748b9c4e
--- /dev/null
+++ b/misc/gretl/files/patch-lib::Makefile.in
@@ -0,0 +1,40 @@
+--- lib/Makefile.in.orig Mon Apr 22 01:43:31 2002
++++ lib/Makefile.in Wed May 1 23:59:51 2002
+@@ -11,8 +11,8 @@
+ XML_CFLAGS = @XML_CFLAGS@
+ XML_LIBS = @XML_LIBS@
+
+-ifeq ($(INSTALL_PROGRAM),)
+- INSTALL_PROGRAM = $(INSTALL) -m 755
++ifeq ($(INSTALL_SCRIPT),)
++ INSTALL_SCRIPT = $(INSTALL) -m 755
+ endif
+ ifeq ($(INSTALL_DATA),)
+ INSTALL_DATA = $(INSTALL) -m 644
+@@ -27,7 +27,7 @@
+
+ # General compile options and libs:
+ LIBGRETL = libgretl.la
+-LIBS = -lm -ldl -L/usr/local/lib -lz $(XML_LIBS)
++LIBS = -lm -lz $(XML_LIBS)
+
+ #### End of system configuration section. ####
+
+@@ -61,14 +61,14 @@
+ .PHONY:
+
+ install: $(LIBGRETL) install-data
+- $(LIBTOOL) $(INSTALL_PROGRAM) $< $(libdir)/$<
++ $(LIBTOOL) $(INSTALL_DATA) $< $(libdir)/$<
+
+ install-strip: $(LIBGRETL) install-data
+- $(LIBTOOL) $(INSTALL_PROGRAM) -s $< $(libdir)/$<
++ $(LIBTOOL) $(INSTALL_DATA) -s $< $(libdir)/$<
+
+ install-data: installdirs
+ $(INSTALL_DATA) $(srcdir)/*.h $(includedir)
+- $(INSTALL_PROGRAM) ../gretl-config $(bindir)
++ $(INSTALL_SCRIPT) ../gretl-config $(bindir)
+
+ installdirs:
+ $(topsrc)/tools/mkinstalldirs $(libdir) $(includedir)
diff --git a/misc/gretl/files/patch-plugin::Makefile.in b/misc/gretl/files/patch-plugin::Makefile.in
new file mode 100644
index 000000000000..1c2311d1564b
--- /dev/null
+++ b/misc/gretl/files/patch-plugin::Makefile.in
@@ -0,0 +1,51 @@
+--- plugin/Makefile.in.orig Thu Mar 28 07:05:24 2002
++++ plugin/Makefile.in Thu May 2 01:46:10 2002
+@@ -2,6 +2,7 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++libdir = @libdir@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+ MAKE = @MAKE@
+@@ -21,7 +22,7 @@
+ endif
+
+ # Installation directory
+-share = $(prefix)/share/gretl
++gretldir = $(libdir)/gretl
+
+ LIBTOOL = $(topsrc)/libtool
+ COMPILE = $(LIBTOOL) --mode=compile $(CC) -c -fPIC -DPIC $(CFLAGS)
+@@ -29,8 +30,8 @@
+
+ GRETLINC = -I$(topsrc)/lib/src
+ GRETLLIB = ../lib/libgretl.la
+-GTKINC = `gtk-config --cflags`
+-GTKLIB = `gtk-config --libs`
++GTKINC = `$(GTK_CONFIG) --cflags`
++GTKLIB = `$(GTK_CONFIG) --libs`
+
+ PLUGINS = stats_tables.so panel_data.so progress_bar.so \
+ gnumeric_import.so excel_import.so
+@@ -85,15 +86,15 @@
+ .PHONY:
+
+ install: $(PLUGINS) installdirs
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) \
+- $(PLUGINS) $(share)/plugins
++ $(LIBTOOL) --mode=install $(INSTALL_DATA) \
++ $(PLUGINS) $(gretldir)/plugins
+
+ install-strip: $(PLUGINS) installdirs
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s \
+- $(PLUGINS) $(share)/plugins
++ $(LIBTOOL) --mode=install $(INSTALL_DATA) -s \
++ $(PLUGINS) $(gretldir)/plugins
+
+ installdirs:
+- $(topsrc)/tools/mkinstalldirs $(share)/plugins
++ $(topsrc)/tools/mkinstalldirs $(gretldir)/plugins
+
+ clean:
+ rm -f *.o *.lo $(PLUGINS) core
diff --git a/misc/gretl/files/patch-plugin::workbook.c b/misc/gretl/files/patch-plugin::workbook.c
new file mode 100644
index 000000000000..968444a7e846
--- /dev/null
+++ b/misc/gretl/files/patch-plugin::workbook.c
@@ -0,0 +1,10 @@
+--- plugin/workbook.c.orig Thu Apr 11 05:33:44 2002
++++ plugin/workbook.c Thu May 2 01:27:51 2002
+@@ -2,6 +2,7 @@
+
+ #include <stdio.h>
+ #include <glib.h>
++#include <wchar.h>
+ #include "biff.h"
+ #include "importer.h"
+
diff --git a/misc/gretl/files/patch-share::Makefile.in b/misc/gretl/files/patch-share::Makefile.in
new file mode 100644
index 000000000000..8c2a6a5c6645
--- /dev/null
+++ b/misc/gretl/files/patch-share::Makefile.in
@@ -0,0 +1,16 @@
+--- share/Makefile.in.orig Thu Mar 28 07:10:47 2002
++++ share/Makefile.in Wed May 1 06:56:53 2002
+@@ -1,10 +1,11 @@
+ topsrc = ..
+
+ prefix = @prefix@
++libdir = @libdir@
+
+-gretldir = $(prefix)/share/gretl
++gretldir = $(libdir)/gretl
+ tooldir = $(topsrc)/tools
+-INSTALL_DATA = cp -fp
++INSTALL_DATA = @INSTALL_DATA@
+
+ .PHONY :
+