summaryrefslogtreecommitdiff
path: root/misc/gpt/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-26 19:44:13 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-26 19:44:13 +0000
commit81250a8ee9bf12d5e3546858c4e476c6ac5adb87 (patch)
treefd5bf52e74f25c9c5825c8c97d7a574b90fe3bf1 /misc/gpt/Makefile
parentChange the default version of ruby to 1.8 for i386 as well, finally. (diff)
Add gpt 3.1,
From the website (http://www.gridpackagingtools.org/): The Grid Packaging Tools are a multiplatform packaging system used to deploy Grid middleware for projects such as the National Science Foundation's Middleware Initiative (NMI) and the Globus Toolkit. PR: ports/61604 Submitted by: Brooks Davis <brooks@freebsd.org>
Diffstat (limited to 'misc/gpt/Makefile')
-rw-r--r--misc/gpt/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/misc/gpt/Makefile b/misc/gpt/Makefile
new file mode 100644
index 000000000000..01213c55d569
--- /dev/null
+++ b/misc/gpt/Makefile
@@ -0,0 +1,60 @@
+# Ports collection makefile for: gpt
+# Date created: January 16, 2004
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpt
+PORTVERSION= 3.1
+CATEGORIES= misc archivers devel parallel
+MASTER_SITES= ftp://ftp.ncsa.uiuc.edu/aces/gpt/releases/gpt-${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= "Grid Packaging Tools (used to install Globus)"
+
+RUN_DEPENDS+= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/IO/Zlib.pm:${PORTSDIR}/archivers/p5-IO-Zlib \
+ ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/bin/gmake:${PORTSDIR}/devel/gmake \
+ ${LOCALBASE}/bin/makepatch:${PORTSDIR}/textproc/makepatch
+
+USE_PERL= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_BUILD= yes
+
+PLIST_SUB+= PERL=${PERL}
+
+MAN1= gpt-build.1 gpt-bundle.1 gpt-config.1 gpt-deps.1 \
+ gpt-flavor-configuration.1 gpt-install.1 \
+ gpt-pkg.1 gpt-postinstall.1 gpt-query.1 gpt-setup.1 \
+ gpt-undefines.1 gpt-uninstall.1 gpt-verify.1 \
+ gpt-virtual-pkg.1 gpt_build_config.1 \
+ gpt_extract_data.1 gpt_generate_bin_pkg_data.1 \
+ gpt_save_flavor.1
+
+FIX_VAR_FILES= ${WRKSRC}/packaging_tools/perl/GPT/Localize.pm \
+ ${WRKSRC}/packaging_tools/perl/GPT/PkgMngmt.pm \
+ ${WRKSRC}/packaging_tools/perl/GPT/PkgMngmt/Archive.pm \
+ ${WRKSRC}/packaging_tools/perl/GPT/PkgMngmt/BuildMacros.pm \
+ ${WRKSRC}/packaging_tools/perl/GPT/PkgMngmt/ExpandSource.pm \
+ ${WRKSRC}/packaging_tools/perl/scripts/gpt-bundle \
+ ${WRKSRC}/packaging_tools/perl/scripts/gpt-config \
+ ${WRKSRC}/tools/testArchiveTar
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|@@PERL@@|${PERL}|g" ${WRKSRC}/build_gpt
+ @${REINPLACE_CMD} -e 's|$$gpath/var/lib/perl|/var/db/gpt|g' ${FIX_VAR_FILES}
+ @${MKDIR} ${WRKSRC}/packaging_tools/etc/gpt
+
+do-install:
+ @cd ${WRKSRC}; \
+ GPT_LOCATION=${PREFIX} ./build_gpt --with-perl=${PERL}
+
+.include <bsd.port.mk>