summaryrefslogtreecommitdiff
path: root/misc/gkrellweather2/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-24 04:14:55 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-24 04:14:55 +0000
commit69606f2f5ef1dc0a538463634f5ffa00744b8f7f (patch)
tree3487839bebc5c34c5cb0a054ad29bbbf279d5c54 /misc/gkrellweather2/Makefile
parentnew port: mail/gkrellmailwatch2 (diff)
New port: misc/gkrellweather2
GKrellM plugin which shows weather info from the US National Weather PR: ports/45666,ports/45663 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Diffstat (limited to 'misc/gkrellweather2/Makefile')
-rw-r--r--misc/gkrellweather2/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
new file mode 100644
index 000000000000..d5c12fd95463
--- /dev/null
+++ b/misc/gkrellweather2/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gkrellweather2
+# Date Created: 24 Nov 2002
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.1.1.1 2002/11/24 03:13:54 jylefort Exp $
+#
+
+PORTNAME= gkrellweather
+PORTVERSION= 2.0.4
+CATEGORIES= misc
+MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@brutele.be
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
+ ${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
+
+USE_X_PREFIX= yes
+
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ MKDIR="${MKDIR}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+
+.include <bsd.port.mk>