summaryrefslogtreecommitdiff
path: root/misc/gkrellweather2/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-22 13:32:52 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-22 13:32:52 +0000
commit551b0bd65103a9f2d8f8e161cb0a8442b2da1ab0 (patch)
tree085bc5ed14bdaa5fe74e6e524675e357a49261e8 /misc/gkrellweather2/Makefile
parent o Delete WWW: line in pkg-desc, cause the site didn't exist anymore (diff)
update misc/gkrellweather2: 2.0.5 -> 2.0.6
PR: 54450 Submitted by: Pav Lucistnik <pav@oook.cz> Reviewed by: Jean-Yves Lefort <jylefort@brutele.be> (maintainer)
Diffstat (limited to 'misc/gkrellweather2/Makefile')
-rw-r--r--misc/gkrellweather2/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index 319365908960..07094f6eca41 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -3,27 +3,31 @@
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
-# $Id: Makefile,v 1.1.1.1 2002/11/24 03:13:54 jylefort Exp $
#
PORTNAME= gkrellweather
-PORTVERSION= 2.0.5
+PORTVERSION= 2.0.6
CATEGORIES= misc
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
EXTRACT_SUFX= .tgz
-MAINTAINER= jylefort@brutele.be
+MAINTAINER= pav@oook.cz
COMMENT= GKrellWeather is a weather plugin for GKrellM
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
+USE_GMAKE= yes
USE_X_PREFIX= yes
+ALL_TARGET= gkrellweather.so
-MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
- MKDIR="${MKDIR}" \
- INSTALL_DATA="${INSTALL_DATA}"
+MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
+ ${INSTALL_DATA} ${WRKSRC}/gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
+ ${MKDIR} ${PREFIX}/share/locale/ru/
+ ${INSTALL_DATA} ${WRKSRC}/po/ru.mo ${PREFIX}/share/locale/ru/LC_MESSAGES/gkrellweather.mo
.include <bsd.port.mk>