summaryrefslogtreecommitdiff
path: root/misc/documancer/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-02 07:50:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-02 07:50:45 +0000
commitd300548af3e515f7d3edeebb48fa3bbdd927e8f0 (patch)
treeff7cbedd48900d2e9dba2e39fbdab0372f9af04d /misc/documancer/Makefile
parentadd wxmozilla 0.5.3 (diff)
add documancer 0.2.3
A programmer's documentation reader
Diffstat (limited to 'misc/documancer/Makefile')
-rw-r--r--misc/documancer/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/documancer/Makefile b/misc/documancer/Makefile
new file mode 100644
index 000000000000..f4ce5f96c28c
--- /dev/null
+++ b/misc/documancer/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: documancer
+# Date created: Oct 27, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= documancer
+PORTVERSION= 0.2.3
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A programmer's documentation reader
+
+BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget \
+ swish-e:${PORTSDIR}/www/swish-e
+LIB_DEPENDS= wxmozilla_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxmozilla
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython
+
+USE_PYTHON= 2.3
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --libdir=${PREFIX}/share
+MAKE_ENV= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>