summaryrefslogtreecommitdiff
path: root/misc/bdelta/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-05-18 16:46:07 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-05-18 16:46:07 +0000
commit89dfb5ebce91b34dec73ac68581d29d3a4225598 (patch)
tree78873f9a7e11cc16b2344fbbf98ec8450ed4b9ef /misc/bdelta/Makefile
parent. Update to 2.1.0. (diff)
Add misc/bdelta - an advanced delta creator, patcher, and library.
Diffstat (limited to 'misc/bdelta/Makefile')
-rw-r--r--misc/bdelta/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/bdelta/Makefile b/misc/bdelta/Makefile
new file mode 100644
index 000000000000..275bac96cd1b
--- /dev/null
+++ b/misc/bdelta/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: bdelta
+# Date created: 2005-05-18
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bdelta
+PORTVERSION= 0.1.0
+CATEGORIES= misc devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= deltup
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= An advanced delta creator, patcher, and library
+
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+PLIST_FILES= bin/bdelta \
+ bin/bpatch \
+ lib/libbdelta.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bdelta ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bpatch ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libbdelta.so ${PREFIX}/lib
+
+.include <bsd.port.mk>