summaryrefslogtreecommitdiff
path: root/misc/222upgrade/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-03-29 07:09:48 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-03-29 07:09:48 +0000
commit3054f9a583100a7152e316ba207297d947235d2f (patch)
treee1fda7961706d0e96baa1744e234af53823370f3 /misc/222upgrade/Makefile
parent(1) Move _sedsubplist generation later, just before it is used. The (diff)
Install /var/db/pkg/.mkversion to check version against bsd.port.mk.
Change IGNORE to FORBIDDEN.
Diffstat (limited to '')
-rw-r--r--misc/222upgrade/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/misc/222upgrade/Makefile b/misc/222upgrade/Makefile
index 9f1075ddfeb3..02c7f45321b1 100644
--- a/misc/222upgrade/Makefile
+++ b/misc/222upgrade/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 Apr 1997
# Whom: asami
#
-# $Id: Makefile,v 1.3 1999/03/09 20:57:22 asami Exp $
+# $Id: Makefile,v 1.4 1999/03/10 22:10:49 asami Exp $
#
DISTNAME= 222upgrade-1998.03.08
@@ -17,11 +17,15 @@ MAINTAINER= asami@Freebsd.ORG
.if !defined(PACKAGE_BUILDING)
BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
.elif ${OSVERSION} >= 300000
-IGNORE= this needs to be built on a 2.2-stable system
+FORBIDDEN= this needs to be built on a 2.2-stable system
.endif
NO_MTREE= yes
PREFIX= /
NO_BUILD= yes
-NO_INSTALL= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
+
+do-install:
+ ${SED} -e "s/%%VERSION%%/${BSDPORTMKVERSION}/" ${PKGDIR}/INSTALL \
+ > ${PKGINSTALL}
.include <bsd.port.post.mk>