summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-02 21:38:09 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-02 21:38:09 +0000
commit4063eccdf2bd0d3ca469e5e96332e58fe5ad72dd (patch)
tree6a21c7eedce3ab02121c1a526e479099181228ef /math
parent- Convert to new perl framework (diff)
- Convert to new perl framework
- Trim Makefile header
Diffstat (limited to 'math')
-rw-r--r--math/p5-AI-Perceptron/Makefile9
-rw-r--r--math/p5-CAD-Calc/Makefile9
-rw-r--r--math/p5-Math-Geometry-Planar-Offset/Makefile9
-rw-r--r--math/p5-Math-Round-Var/Makefile9
4 files changed, 12 insertions, 24 deletions
diff --git a/math/p5-AI-Perceptron/Makefile b/math/p5-AI-Perceptron/Makefile
index 936615701e11..0a917e5f23d0 100644
--- a/math/p5-AI-Perceptron/Makefile
+++ b/math/p5-AI-Perceptron/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: AI-Perceptron
-# Date created: 04 Nov 2000
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= AI-Perceptron
PORTVERSION= 1.0
@@ -17,7 +13,8 @@ COMMENT= Perl module for introducing to internal operations of neural networks
BUILD_DEPENDS= p5-accessors>=0:${PORTSDIR}/devel/p5-accessors
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= AI::Perceptron.3
diff --git a/math/p5-CAD-Calc/Makefile b/math/p5-CAD-Calc/Makefile
index 8f778981cfc4..f5aaac3695fd 100644
--- a/math/p5-CAD-Calc/Makefile
+++ b/math/p5-CAD-Calc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: CAD-Calc
-# Date created: 21 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= CAD-Calc
PORTVERSION= 0.27
@@ -22,6 +18,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= CAD::Calc.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/math/p5-Math-Geometry-Planar-Offset/Makefile b/math/p5-Math-Geometry-Planar-Offset/Makefile
index f64a55bf63cf..38b24d8c754d 100644
--- a/math/p5-Math-Geometry-Planar-Offset/Makefile
+++ b/math/p5-Math-Geometry-Planar-Offset/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math-Geometry-Planar-Offset
-# Date created: 21 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-Geometry-Planar-Offset
PORTVERSION= 1.05
@@ -19,6 +15,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Geometry::Planar::Offset.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/math/p5-Math-Round-Var/Makefile b/math/p5-Math-Round-Var/Makefile
index db971d32e351..c936cffdbf3e 100644
--- a/math/p5-Math-Round-Var/Makefile
+++ b/math/p5-Math-Round-Var/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math-Round-Var
-# Date created: 21 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-Round-Var
PORTVERSION= 1.0.0
@@ -17,6 +13,7 @@ COMMENT= Variations on rounding
MAN3= Math::Round::Var.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>