summaryrefslogtreecommitdiff
path: root/math/siag/files
diff options
context:
space:
mode:
authorJun-ichiro itojun Hagino <itojun@FreeBSD.org>1998-02-28 03:38:33 +0000
committerJun-ichiro itojun Hagino <itojun@FreeBSD.org>1998-02-28 03:38:33 +0000
commit2d59ff4aad762713418239125450a9644349c4d6 (patch)
tree90d3eeda660955f30b673f9e469aad2627045b82 /math/siag/files
parentUpdate to version 1.4 (diff)
siag, "scheme in a grid" spreadsheet.
Diffstat (limited to 'math/siag/files')
-rw-r--r--math/siag/files/patch-aa54
-rw-r--r--math/siag/files/patch-ac54
-rw-r--r--math/siag/files/patch-ae11
-rw-r--r--math/siag/files/patch-af11
4 files changed, 130 insertions, 0 deletions
diff --git a/math/siag/files/patch-aa b/math/siag/files/patch-aa
new file mode 100644
index 000000000000..da215d1a3156
--- /dev/null
+++ b/math/siag/files/patch-aa
@@ -0,0 +1,54 @@
+--- topdir.mk.orig Fri Jan 23 05:03:22 1998
++++ topdir.mk Wed Jan 28 03:08:06 1998
+@@ -1,10 +1,10 @@
+
+ # Set this to wherever you unpacked the archive.
+ # This is normally not needed, it should be autodetected
+-#SIAG_HOME = -DSIAGHOME=\"/usr/local/siag\"
++SIAG_HOME = -DSIAGHOME=\"${PREFIX}/lib/siag\"
+
+ # Set this to your web browser of choice
+ SIAG_HELP = -DSIAGHELP=\"chimera\"
+
+ # This creates a file TRACEME in the current directory
+ #DEBUG = -DDEBUG
+@@ -25,11 +25,12 @@
+ NDBM = -DNDBM
+ # And one of the following two lines
+ #DBLIB = -lndbm
+-DBLIB = -ldb
++#DBLIB = -ldb
+
+ # Uncomment one of the following:
+-SYSDEP_LIB = # for Linux or HP/UX
++#SYSDEP_LIB = # for Linux or HP/UX
+ #SYSDEP_LIB = -lposix4 # for Solaris
++SYSDEP_LIB = -lcrypt # FreeBSD
+
+
+ ######
+@@ -69,7 +70,7 @@
+
+ ######
+ # Uncomment this if you want to use Xaw3d widgets
+-XAW3D = -lXaw3d
++#XAW3D = -lXaw3d
+ # Or this if you have Xaw95 widgets installed
+ #XAW3D = -lXaw95
+ # Or this for a NeXT look
+@@ -83,11 +84,11 @@
+
+ ######
+ # To use Guile (requires libguile)
+-GUILE = -DGUILE
+-GUILELIB = -lguile
++#GUILE = -DGUILE
++#GUILELIB = -lguile
+ # To use Tcl (requires libtcl)
+-TCL = -DTCL
+-TCLLIB = -ltcl -ldl
++#TCL = -DTCL
++#TCLLIB = -ltcl -ldl
+ # To use Perl (requires installed Perl library)
+ # There is *no* Perl support in Siag yet!
+ #PERL = -DPERL
diff --git a/math/siag/files/patch-ac b/math/siag/files/patch-ac
new file mode 100644
index 000000000000..928028ab9371
--- /dev/null
+++ b/math/siag/files/patch-ac
@@ -0,0 +1,54 @@
+--- siod/slibu.c.orig Wed Jan 28 02:32:30 1998
++++ siod/slibu.c Wed Jan 28 02:33:37 1998
+@@ -28,6 +28,7 @@
+ #include <pwd.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
++#include <sys/syslimits.h>
+ #include <sys/resource.h>
+ #include <grp.h>
+ #include <utime.h>
+@@ -258,6 +259,7 @@
+ return(NIL);}
+ #endif
+
++#if !defined(__FreeBSD__)
+ LISP lputpwent(LISP alist,LISP file)
+ {int iflag = no_interrupt(1);
+ int status;
+@@ -266,6 +268,7 @@
+ status = putpwent(&p,get_c_file(file,NULL));
+ no_interrupt(iflag);
+ return(NIL);}
++#endif
+
+ LISP laccess_problem(LISP lfname,LISP lacc)
+ {char *fname = get_c_string(lfname);
+@@ -1413,7 +1416,7 @@
+ #endif
+
+ /* Ulric was here: added hpux */
+-#if defined(unix) && !defined(linux) && !defined(hpux)
++#if defined(unix) && !defined(linux) && !defined(hpux) && !defined(__FreeBSD__)
+ LISP l_lchown(LISP path,LISP uid,LISP gid)
+ {long iflag;
+ iflag = no_interrupt(1);
+@@ -1930,7 +1933,9 @@
+ #if defined(__osf__)
+ init_subr_1("setpwfile",lsetpwfile);
+ #endif
++#if !defined(__FreeBSD__)
+ init_subr_2("putpwent",lputpwent);
++#endif
+ init_subr_2("access-problem?",laccess_problem);
+ init_subr_3("utime",lutime);
+ init_subr_2("chmod",lchmod);
+@@ -2010,7 +2015,7 @@
+ init_subr_3("chown",l_chown);
+ #endif
+ /* Ulric was here: added hpux */
+-#if defined(unix) && !defined(linux) && !defined(hpux)
++#if defined(unix) && !defined(linux) && !defined(hpux) && !defined(__FreeBSD__)
+ init_subr_3("lchown",l_lchown);
+ #endif
+ init_subr_1("http-date",http_date);
diff --git a/math/siag/files/patch-ae b/math/siag/files/patch-ae
new file mode 100644
index 000000000000..71ea2e74f597
--- /dev/null
+++ b/math/siag/files/patch-ae
@@ -0,0 +1,11 @@
+--- tsiag/window.c.orig Wed Jan 28 02:38:18 1998
++++ tsiag/window.c Wed Jan 28 02:38:24 1998
+@@ -27,7 +27,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include "../common/cmalloc.h"
+-#include <curses.h>
++#include <ncurses.h>
+
+ #include "../siag/types.h"
+ #include "../siag/calc.h"
diff --git a/math/siag/files/patch-af b/math/siag/files/patch-af
new file mode 100644
index 000000000000..2112b00e8bec
--- /dev/null
+++ b/math/siag/files/patch-af
@@ -0,0 +1,11 @@
+--- tsiag/tsiag.c.orig Wed Jan 28 02:39:28 1998
++++ tsiag/tsiag.c Wed Jan 28 02:39:34 1998
+@@ -2,7 +2,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <curses.h>
++#include <ncurses.h>
+ #include "../siod/siod.h"
+ #include "../siag/types.h"
+ #include "../siag/calc.h"