summaryrefslogtreecommitdiff
path: root/math/plplot
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-06-13 16:07:11 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-06-13 16:07:11 +0000
commit38402701f87718ae65bd41f136a9b2d8d78661a1 (patch)
treea5ab71bfdcb59cfd0ec57fe5a2993a7db5dcfc78 /math/plplot
parentUpgrade to version 2.0.1 (diff)
Update to version 5.0.3
PR: 28055 Submitted by: Ports Fury
Diffstat (limited to 'math/plplot')
-rw-r--r--math/plplot/Makefile43
-rw-r--r--math/plplot/distinfo4
-rw-r--r--math/plplot/files/patch-aa153
-rw-r--r--math/plplot/files/patch-ab90
-rw-r--r--math/plplot/files/patch-ac13
-rw-r--r--math/plplot/files/patch-ad18
-rw-r--r--math/plplot/files/patch-ae49
-rw-r--r--math/plplot/files/patch-af11
-rw-r--r--math/plplot/files/patch-ag43
-rw-r--r--math/plplot/files/patch-ah23
-rw-r--r--math/plplot/pkg-descr2
-rw-r--r--math/plplot/pkg-plist107
12 files changed, 231 insertions, 325 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 6df0fe14c629..e3dab112e8bd 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -6,30 +6,35 @@
#
PORTNAME= plplot
-PORTVERSION= 4.99j
+PORTVERSION= 5.0.3
CATEGORIES= math
-MASTER_SITES= ftp://ftp.uniovi.es/pub6/graphics/plotting/ \
- ftp://dino.ph.utexas.edu/plplot/distrib/alpha/ \
- ftp://ftp.che.utexas.edu/pub/graphics/
-DISTNAME= ${PORTNAME}4p99j
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${DISTNAME}.patch1.gz
+PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
USE_XLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gcc=yes --with-double=yes
+CONFIGURE_ENV= F77="${FC}" FFLAGS="${FFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ GDINCDIR="${LOCALBASE}/include/gd" \
+ GDLIBDIR="${LOCALBASE}/lib" \
+ XINCDIR="${X11BASE}/include" \
+ XLIBDIR="${X11BASE}/lib" \
+ PLPLOT_PREFIX="${PREFIX}/share/plplot" \
+ DEMOS_DIR="${PREFIX}/share/examples/plplot" \
+ INFO_DIR="${PREFIX}/info" \
+ M4="${LOCALBASE}/bin/gm4"
+CONFIGURE_ARGS= --disable-tk --disable-tcl --disable-itcl --disable-python \
+ --with-double
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/*.c
-
-post-install:
-.if ${PORTOBJFORMAT} == "elf"
- ${LN} -sf libplplotdX.so.4 ${PREFIX}/lib/libplplotdX.so
-.else
- ${LN} -sf libplplotdX.so.4.99 ${PREFIX}/lib/libplplotdX.so
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/plplot/distinfo b/math/plplot/distinfo
index 25cd015dfe03..5e43558b1842 100644
--- a/math/plplot/distinfo
+++ b/math/plplot/distinfo
@@ -1,2 +1,2 @@
-MD5 (plplot4p99j.tar.gz) = e0914f2aa5216b1eeef559a73e9f2af5
-MD5 (plplot4p99j.tar.gz) = 77df50c8d6ebccd7007446ba8420f21a
+MD5 (plplot-5.0.3.tar.gz) = 1ba5bcf8d7b19960742391e7326b05d4
+MD5 (plplot-5.0.3.patch1.gz) = 562ccb5be2294e657f63720e728f91a2
diff --git a/math/plplot/files/patch-aa b/math/plplot/files/patch-aa
index 43b771cb94c0..17fd33f8a09d 100644
--- a/math/plplot/files/patch-aa
+++ b/math/plplot/files/patch-aa
@@ -1,96 +1,69 @@
---- configure.orig Wed Jun 7 04:58:50 1995
-+++ configure Wed Jan 5 00:15:16 2000
-@@ -1175,10 +1175,10 @@
- # ----------------------------------------------------------------------------
-
- if test "$with_gcc" = "yes"; then
-- CC=gcc
-- CXX=gcc
-- OCC="gcc -traditional"
-- CPP="gcc -E"
-+ CC=$CC
-+ CXX=$CXX
-+ OCC="$CC -traditional"
-+ CPP="$CC -E"
-
- if test "$with_warn" = "yes"; then
- SYS_FLAGS_C=-Wall
-@@ -1472,13 +1472,13 @@
- # ----------------------------------------------------------------------------
+--- configure.orig Fri Mar 30 04:55:57 2001
++++ configure Sat Apr 28 11:41:53 2001
+@@ -1262,7 +1262,9 @@
- CC_FLAGS=\
--"-c $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $OPT_FLAG_C"
-+"-c $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $CFLAGS"
+ # Defaults
- CXX_FLAGS=\
--"-c $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $OPT_FLAG_CXX"
-+"-c $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $CXXFLAGS"
-
- F77_FLAGS=\
--"-c $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $OPT_FLAG_F"
-+"-c $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $FFLAGS"
-
- LDC_FLAGS=\
- "$PROF_FLAG_LC $SYS_FLAGS_LC $DEBUG_FLAG_LC"
-@@ -3062,6 +3062,20 @@
- # Hmm, would be good to replace that trailing .0 with the
- # compilation number or some such. Have to think about that.
- ;;
-+ FreeBSD*|NetBSD*|OpenBSD* )
-+ SHLIB_CCFLAGS="-fpic -DPIC"
-+ SHLIB_CXXFLAGS="-fpic -DPIC"
-+ if [ "${PORTOBJFORMAT}" = "elf" ]; then
-+ SO='.so.$(MAJOR_VERSION)'
-+ SHLIB_BUILD="ld -shared -soname \$@ -o"
-+ SOVERSION='$(MAJOR_VERSION)'
-+ else
-+ SO='.so.$(MAJOR_VERSION).$(MINOR_VERSION)'
-+ SHLIB_BUILD="ld -Bshareable -o"
-+ SOVERSION='$(MAJOR_VERSION).$(MINOR_VERSION)'
-+ fi
-+ echo "$ac_t""okay" 1>&6
-+ ;;
- HP-UX-* )
- SO=".sl"
- SHLIB_F77FLAGS="+z"
-@@ -4192,16 +4206,19 @@
- fi
- fi
- if test -z "$DOC_DIR"; then
-- DOC_DIR=$prefix/doc
-+ DOC_DIR=$prefix/share/doc/plplot
- fi
- if test -z "$INFO_DIR"; then
- INFO_DIR=$prefix/info
- fi
- if test -z "$INCLUDE_DIR"; then
-- INCLUDE_DIR=$prefix/include
-+ INCLUDE_DIR=$prefix/include/plplot
- fi
- if test -z "$DEMOS_DIR"; then
-- DEMOS_DIR=$prefix/examples
-+ DEMOS_DIR=$prefix/share/examples/plplot
+-M4=m4
++if test -z "$M4"; then
++ M4=m4
+fi
-+if test -z "$DATA_DIR"; then
-+ DATA_DIR=$prefix/share/plplot
- fi
-
- cat >> confdefs.h <<EOF
-@@ -4216,6 +4233,9 @@
- #define TCL_DIR "$TCL_DIR"
- EOF
-+cat >> confdefs.h <<EOF
-+#define DATA_DIR "$DATA_DIR"
-+EOF
+ # Double precision
+ # Note that because there is no standard way to invoke double
+@@ -1530,9 +1532,9 @@
+ # Optimization
+ if test "$with_opt" = "yes"; then
+- OPT_FLAG_C=-O
+- OPT_FLAG_CXX=-O
+- OPT_FLAG_F=-O
++ OPT_FLAG_C="$CFLAGS"
++ OPT_FLAG_CXX="$CXXFLAGS"
++ OPT_FLAG_F="$FFLAGS"
+ fi
-
-@@ -4449,6 +4469,7 @@
- s%@INFO_DIR@%$INFO_DIR%g
- s%@INCLUDE_DIR@%$INCLUDE_DIR%g
- s%@DEMOS_DIR@%$DEMOS_DIR%g
-+s%@DATA_DIR@%$DATA_DIR%g
- s%@SHARED@%$SHARED%g
-
- CEOF
+ # ----------------------------------------------------------------------------
+@@ -4628,6 +4630,13 @@
+ EXTRA_LIBS="-ldl -lm"
+ fi
+ ;;
++ FreeBSD* )
++ if test "$enable_f77" = "yes"; then
++ EXTRA_LIBS="$EXTRA_LIBS -lm -lg2c"
++ else
++ EXTRA_LIBS="$EXTRA_LIBS -lm"
++ fi
++ ;;
+ * )
+ echo $ac_n "checking for main in -lXbsd""... $ac_c" 1>&6
+ echo "configure:4634: checking for main in -lXbsd" >&5
+@@ -4909,6 +4918,20 @@
+ # for Linux.)
+ SHLIB_F77FLAGS=-fPIC
+ ;;
++ FreeBSD* )
++ SHLIB_CCFLAGS="-fpic -DPIC"
++ SHLIB_CXXFLAGS="-fpic -DPIC"
++ echo "$ac_t""okay" 1>&6
++ if [ "${PORTOBJFORMAT}" = "elf" ]; then
++ SO='.so.$(MAJOR_VERSION)'
++ SHLIB_BUILD="$CC -shared -Wl,-soname -Wl,\$@ -o"
++ SOVERSION='$(MAJOR_VERSION)'
++ else
++ SO='.so.$(MAJOR_VERSION).$(MINOR_VERSION)'
++ SHLIB_BUILD="ld -Bshareable -o"
++ SOVERSION='$(MAJOR_VERSION).$(MINOR_VERSION)'
++ fi
++ ;;
+ HP-UX-* )
+ SO=".sl"
+ SHLIB_F77FLAGS="+z"
+@@ -6600,6 +6623,7 @@
+ s%@LDCXX_FLAGS@%$LDCXX_FLAGS%g
+ s%@F77_FLAGS@%$F77_FLAGS%g
+ s%@LDF_FLAGS@%$LDF_FLAGS%g
++s%@M4@%$M4%g
+ s%@M4_FLAGS@%$M4_FLAGS%g
+ s%@CPP@%$CPP%g
+ s%@STUPIDTK_OBJ@%$STUPIDTK_OBJ%g
diff --git a/math/plplot/files/patch-ab b/math/plplot/files/patch-ab
index fd8442e1158a..7c3fbc245887 100644
--- a/math/plplot/files/patch-ab
+++ b/math/plplot/files/patch-ab
@@ -1,58 +1,38 @@
---- cf/install.in.orig Wed Jun 7 03:13:09 1995
-+++ cf/install.in Wed Jan 5 02:26:56 2000
-@@ -31,19 +31,18 @@
- -if test ! -d $(DOC_DIR); then mkdir -p $(DOC_DIR); fi
- -if test ! -d $(BIN_DIR); then mkdir -p $(BIN_DIR); fi
- -if test ! -d $(INFO_DIR); then mkdir -p $(INFO_DIR); fi
-- -cd $(top_srcdir)/lib; cp *.fnt *.map $(LIB_DIR)
-- -cp $(PLLIB_BASE)* $(LIB_DIR); \
-- for file in $(PLLIB_BASE)*; do $(RANLIB) $(LIB_DIR)/$$file; done
-+ -if test ! -d $(DATA_DIR); then mkdir -p $(DATA_DIR); fi
-+ -cd $(top_srcdir)/lib; ${BSD_INSTALL_DATA} *.fnt *.map $(DATA_DIR)
-+ ${BSD_INSTALL_DATA} $(PLLIB_BASE)* $(LIB_DIR); \
-+ for file in $(PLLIB_BASE)*.a; do $(RANLIB) $(LIB_DIR)/$$file; done
- -cd $(top_srcdir); \
-- cp README NEWS CHANGES Copyright COPYING.LIB FAQ ToDo \
-- mklinks $(DOC_DIR)
-+ ${BSD_INSTALL_DATA} README NEWS CHANGES FAQ ToDo mklinks $(DOC_DIR)
- -if test ! -f $(DOC_DIR)/README.local; then \
-- cp $(top_srcdir)/doc/README.local $(DOC_DIR); fi
-- -cp $(top_srcdir)/doc/*.info $(INFO_DIR)
-- -cd $(top_srcdir)/scripts; cp pl* $(BIN_DIR)
-+ ${BSD_INSTALL_DATA} $(top_srcdir)/doc/README.local $(DOC_DIR); fi
-+ -cd $(top_srcdir)/scripts; ${BSD_INSTALL_SCRIPT} pl* $(BIN_DIR)
- -cd $(top_srcdir)/include; \
-- cp plplotP.h plplot.h plxwd.h plevent.h plstrm.h pdf.h \
-- $(INCLUDE_DIR)
-+ ${BSD_INSTALL_DATA} plplotP.h plplot.h plxwd.h plevent.h plstrm.h \
-+ pdf.h $(INCLUDE_DIR)
-
+--- cf/install.in.orig Tue Mar 27 10:01:46 2001
++++ cf/install.in Sat Apr 28 07:55:00 2001
+@@ -32,28 +32,26 @@
install_demos:
- -if test ! -d $(DEMOS_DIR); then mkdir -p $(DEMOS_DIR); fi
-@@ -56,11 +55,11 @@
- -$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/c
- -$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/f77
- -$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/tk
-- -cd $(top_srcdir)/examples/c; cp * $(DEMOS_DIR)/c
-- -cd $(top_srcdir)/examples/f77; cp * $(DEMOS_DIR)/f77
-- -cd $(top_srcdir)/examples/python; cp * $(DEMOS_DIR)/python
-- -cd $(top_srcdir)/examples/tcl; cp * $(DEMOS_DIR)/tcl
-- -cd $(top_srcdir)/examples/tk; cp * $(DEMOS_DIR)/tk
-+ -cd $(top_srcdir)/examples/c; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/c
-+ -cd $(top_srcdir)/examples/f77; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/f77
-+ -cd $(top_srcdir)/examples/python; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/python
-+ -cd $(top_srcdir)/examples/tcl; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/tcl
-+ -cd $(top_srcdir)/examples/tk; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/tk
- -$(LN) $(DEMOS_DIR)/tcl/x??.tcl $(DEMOS_DIR)/tk
+ @-if test ! -d $(DEMOS_DIR); then mkdir -p $(DEMOS_DIR); fi; \
+ if test ! -d $(DEMOS_DIR)/c; then mkdir -p $(DEMOS_DIR)/c; fi; \
+- $(CP) Makedemo $(DEMOS_DIR)/Makefile; \
+- $(CP) ../test/test_*.sh plplot-test.sh $(DEMOS_DIR); \
++ ${BSD_INSTALL_DATA} Makedemo $(DEMOS_DIR)/Makefile; \
++ ${BSD_INSTALL_DATA} ../test/test_*.sh plplot-test.sh $(DEMOS_DIR); \
+ chmod a+x $(DEMOS_DIR)/plplot-test.sh; \
+ $(LN) ../Makefile $(DEMOS_DIR)/c; \
+ cd $(top_srcdir)/examples/c; \
+- $(CP) *.c $(DEMOS_DIR)/c; \
+- $(CP) *.h $(INCLUDE_DIR)
++ ${BSD_INSTALL_DATA} *.c $(DEMOS_DIR)/c; \
++ ${BSD_INSTALL_DATA} *.h $(INCLUDE_DIR)
+
+ install_plrender:
+ @-if test $(SHARED) = 1; then \
+ $(LDC) $(LDC_FLAGS) plrender$O $(LIB_INSTALL) \
+ -o plrender$E $(LDC_LIBS) $(INSTALL_RPATH); \
+ fi; \
+- strip plrender$E; \
+- $(CP) plrender$E $(BIN_DIR)
++ ${BSD_INSTALL_PROGRAM} plrender$E $(BIN_DIR)
+
+ install_pltek:
+- @-strip pltek$E; $(CP) pltek$E $(BIN_DIR)
++ @${BSD_INSTALL_PROGRAM} pltek$E $(BIN_DIR)
+
+ install_plplot_config:
+- @$(CP) plplot-config $(BIN_DIR); \
+- chmod a+x $(BIN_DIR)/plplot-config
++ @${BSD_INSTALL_SCRIPT} plplot-config $(BIN_DIR)
- install_utils:
-@@ -72,8 +71,7 @@
- $(LDC) $(LDC_FLAGS) pltek$O $(LIB_INSTALL) \
- -o pltek$E; \
- fi
-- -strip plrender$E pltek$E
-- -cp plrender$E pltek$E $(BIN_DIR)
-+ ${BSD_INSTALL_PROGRAM} plrender$E pltek$E $(BIN_DIR)
+ install_utils: install_plrender install_pltek install_plplot_config
- # Remember, this is bogus...
- # $(LDC) $(LDC_FLAGS) pltek$O $(LIB_INSTALL) \
diff --git a/math/plplot/files/patch-ac b/math/plplot/files/patch-ac
deleted file mode 100644
index d2bc00e8b1ac..000000000000
--- a/math/plplot/files/patch-ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- drivers/tek.c.orig Sat Sep 26 23:07:07 1998
-+++ drivers/tek.c Sat Sep 26 23:07:28 1998
-@@ -79,8 +79,8 @@
- static void tty_atexit (void);
- #else
- static void tty_setup (void) {};
--static int tty_cbreak (void) {return 0};
--static int tty_reset (void) {return 0};
-+static int tty_cbreak (void) {return 0;};
-+static int tty_reset (void) {return 0;};
- static void tty_atexit (void) {};
- #endif
-
diff --git a/math/plplot/files/patch-ad b/math/plplot/files/patch-ad
index ddf31ae5bd22..dceffcd32498 100644
--- a/math/plplot/files/patch-ad
+++ b/math/plplot/files/patch-ad
@@ -1,7 +1,11 @@
---- cf/init.in.orig Mon May 15 16:54:21 1995
-+++ cf/init.in Wed Jan 5 01:26:07 2000
-@@ -58,3 +58,4 @@
- INCLUDE_DIR = @INCLUDE_DIR@
- TCL_DIR = @TCL_DIR@
- DEMOS_DIR = @DEMOS_DIR@
-+DATA_DIR = @DATA_DIR@
+--- cf/init.in.orig Mon Mar 26 17:10:40 2001
++++ cf/init.in Sat Apr 28 01:19:12 2001
+@@ -21,7 +21,7 @@
+ OCC = @OCC@
+ F77 = @F77@
+ LDF = @LDF@
+-M4 = m4
++M4 = @M4@
+
+ # Force everything. If unsure, test for existence first.
+ # Redefine these as needed in system-specific setup.
diff --git a/math/plplot/files/patch-ae b/math/plplot/files/patch-ae
deleted file mode 100644
index 530df031e806..000000000000
--- a/math/plplot/files/patch-ae
+++ /dev/null
@@ -1,49 +0,0 @@
---- src/plctrl.c.orig Sat May 27 05:20:57 1995
-+++ src/plctrl.c Wed Jan 5 01:50:02 2000
-@@ -131,7 +131,7 @@
- /* Anything else is assumed to be Unix */
-
- #ifndef PLLIBDEV
--#define PLLIBDEV "/usr/local/plplot/lib"
-+#define PLLIBDEV "%%PREFIX%%/share/plplot"
- #endif
-
- #endif
-@@ -1153,7 +1153,7 @@
- * PLPLOT_LIB_ENV = $(PLPLOT_LIB)
- * current directory
- * PLPLOT_HOME_ENV/lib = $(PLPLOT_HOME)/lib
-- * LIB_DIR
-+ * DATA_DIR
- * PLLIBDEV
- \*--------------------------------------------------------------------------*/
-
-@@ -1195,12 +1195,12 @@
-
- /**** search installed location ****/
-
--#if defined (LIB_DIR)
-- plGetName(LIB_DIR, "", fn, &fs);
-+#if defined (DATA_DIR)
-+ plGetName(DATA_DIR, "", fn, &fs);
-
- if ((file = fopen(fs, "rb")) != NULL)
- goto done;
--#endif /* LIB_DIR */
-+#endif /* DATA_DIR */
-
- /**** search hardwired location ****/
-
-@@ -1215,9 +1215,9 @@
-
- pltext();
- fprintf(stderr, "\nCannot open library file: %s\n", fn);
--#if defined (LIB_DIR)
-- fprintf(stderr, "lib dir=\"" LIB_DIR "\"\n" ); /* what WAS set? */
--#endif /* LIB_DIR */
-+#if defined (DATA_DIR)
-+ fprintf(stderr, "lib dir=\"" DATA_DIR "\"\n" ); /* what WAS set? */
-+#endif /* DATA_DIR */
- plgra();
- return NULL;
-
diff --git a/math/plplot/files/patch-af b/math/plplot/files/patch-af
deleted file mode 100644
index 3c281ffe6ccd..000000000000
--- a/math/plplot/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- utils/pltek.c.orig Fri Sep 16 12:45:46 1994
-+++ utils/pltek.c Tue Jan 4 20:49:26 2000
-@@ -110,7 +110,7 @@
- oldpage = ipage;
- printf("Page %d/%d> ", ipage, npage);
-
-- gets(ibuf);
-+ fgets(ibuf, sizeof(ibuf), stdin);
- c = ibuf[0];
-
- /* User input a page number or a return */
diff --git a/math/plplot/files/patch-ag b/math/plplot/files/patch-ag
new file mode 100644
index 000000000000..e5729c781433
--- /dev/null
+++ b/math/plplot/files/patch-ag
@@ -0,0 +1,43 @@
+--- cf/inst_lib.in.orig Sat Feb 17 07:35:23 2001
++++ cf/inst_lib.in Sat Apr 28 07:49:40 2001
+@@ -16,30 +16,33 @@
+ if test ! -d $(INFO_DIR); then mkdir -p $(INFO_DIR); fi
+
+ install_fonts:
+- @-cd $(top_srcdir)/lib; $(CP) *.fnt *.map $(DATA_DIR)
++ @-cd $(top_srcdir)/lib; ${BSD_INSTALL_DATA} *.fnt *.map $(DATA_DIR)
+
+ install_libbase:
+ @-( cd $(LIB_DIR); $(RM) $(PLLINKS) ) ; \
+- $(CP) $(PLLIB_BASE)* $(LIB_DIR); \
++ ${BSD_INSTALL_DATA} $(PLLIB_BASE)* $(LIB_DIR); \
+ if test -r $(PLLIB_BASE)$(LIB_TAG)$A; then \
+ $(RANLIB) $(LIB_DIR)/$(PLLIB_BASE)$(LIB_TAG)$A; \
++ fi; \
++ if test -f $(LIB_DIR)/$(PLLIB_SO); then \
++ $(LN) $(PLLIB_SO) $(LIB_DIR)/$(PLLIB_BASE)$(LIB_TAG).so ; \
+ fi
+
+ install_textfiles:
+ @-cd $(top_srcdir); \
+- $(CP) README NEWS CHANGES Copyright COPYING.LIB FAQ ToDo mklinks \
++ ${BSD_INSTALL_DATA} README NEWS CHANGES Copyright COPYING.LIB FAQ ToDo mklinks \
+ $(DOC_DIR); \
+ if test ! -f $(DOC_DIR)/README.local; then \
+- $(CP) $(top_srcdir)/doc/README.local $(DOC_DIR); \
++ ${BSD_INSTALL_DATA} $(top_srcdir)/doc/README.local $(DOC_DIR); \
+ fi
+
+ install_scriptfiles:
+- @-cd $(top_srcdir)/scripts; $(CP) pl* $(BIN_DIR)
++ @-cd $(top_srcdir)/scripts; ${BSD_INSTALL_SCRIPT} pl* $(BIN_DIR)
+
+ install_includes:
+- @-$(CP) plConfig.h plDevs.h $(INCLUDE_DIR); \
++ @-${BSD_INSTALL_DATA} plConfig.h plDevs.h $(INCLUDE_DIR); \
+ cd $(top_srcdir)/include; \
+- $(CP) plplotP.h plplot.h plxwd.h plevent.h plstrm.h pdf.h \
++ ${BSD_INSTALL_DATA} plplotP.h plplot.h plxwd.h plevent.h plstrm.h pdf.h \
+ pldebug.h drivers.h $(INCLUDE_DIR)
+
+ install_lib: install_dirs install_fonts install_libbase \
diff --git a/math/plplot/files/patch-ah b/math/plplot/files/patch-ah
new file mode 100644
index 000000000000..e04d6d400a85
--- /dev/null
+++ b/math/plplot/files/patch-ah
@@ -0,0 +1,23 @@
+--- cf/pkg_cxx.in.orig Sat Feb 3 09:36:16 2001
++++ cf/pkg_cxx.in Sat Apr 28 07:11:10 2001
+@@ -32,17 +32,17 @@
+ # Targets
+
+ install_cxx_includes:
+- @-cd $(top_srcdir)/bindings/c++; $(CP) plstream.h $(INCLUDE_DIR)
++ @-cd $(top_srcdir)/bindings/c++; ${BSD_INSTALL_DATA} plstream.h $(INCLUDE_DIR)
+
+ install_cxx_demos:
+ @-if test ! -d $(DEMOS_DIR)/c++; then mkdir -p $(DEMOS_DIR)/c++; fi; \
+ $(LN) ../Makefile $(DEMOS_DIR)/c++; \
+- cd $(top_srcdir)/examples/c++; $(CP) *.cc $(DEMOS_DIR)/c++
++ cd $(top_srcdir)/examples/c++; ${BSD_INSTALL_DATA} *.cc $(DEMOS_DIR)/c++
+
+ install_cxx: install_cxx_includes install_cxx_demos
+
+ install_cxxlib:
+- @-$(CP) $(CXXLIB_BASE)* $(LIB_DIR); \
++ @-${BSD_INSTALL_DATA} $(CXXLIB_BASE)* $(LIB_DIR); \
+ if test -r $(CXXLIB_BASE)$(LIB_TAG)$A; then \
+ $(RANLIB) $(LIB_DIR)/$(CXXLIB_BASE)$(LIB_TAG)$A; \
+ fi
diff --git a/math/plplot/pkg-descr b/math/plplot/pkg-descr
index a1909083eddc..2f576c6ed369 100644
--- a/math/plplot/pkg-descr
+++ b/math/plplot/pkg-descr
@@ -12,4 +12,4 @@ scaled to any desired size. A variety of output devices are supported and
new devices can be easily added by writing a small number of device
dependent routines.
-WWW: http://emma.la.asu.edu/plplot/
+WWW: http://plplot.sourceforge.net/
diff --git a/math/plplot/pkg-plist b/math/plplot/pkg-plist
index 1218977250a6..cd67e373b076 100644
--- a/math/plplot/pkg-plist
+++ b/math/plplot/pkg-plist
@@ -1,18 +1,27 @@
bin/plm2gif
+bin/plplot-config
bin/plpr
bin/plrender
bin/pltek
+include/plplot/drivers.h
include/plplot/pdf.h
+include/plplot/plConfig.h
+include/plplot/plDevs.h
+include/plplot/plcdemos.h
+include/plplot/pldebug.h
include/plplot/plevent.h
include/plplot/plplot.h
include/plplot/plplotP.h
include/plplot/plstream.h
include/plplot/plstrm.h
include/plplot/plxwd.h
-lib/libplplotdX.a
-lib/libplplotdX.so
-lib/libplplotdX.so.4
+lib/libplcxxd.a
+lib/libplplotd.a
+lib/libplplotd.so
+lib/libplplotd.so.5
share/doc/plplot/CHANGES
+share/doc/plplot/COPYING.LIB
+share/doc/plplot/Copyright
share/doc/plplot/FAQ
share/doc/plplot/NEWS
share/doc/plplot/README
@@ -20,8 +29,9 @@ share/doc/plplot/README.local
share/doc/plplot/ToDo
share/doc/plplot/mklinks
share/examples/plplot/Makefile
+share/examples/plplot/c++/Makefile
+share/examples/plplot/c++/x01cc.cc
share/examples/plplot/c/Makefile
-share/examples/plplot/c/plcdemos.h
share/examples/plplot/c/tutor.c
share/examples/plplot/c/x01c.c
share/examples/plplot/c/x02c.c
@@ -57,83 +67,24 @@ share/examples/plplot/f77/x11f.f
share/examples/plplot/f77/x12f.f
share/examples/plplot/f77/x13f.f
share/examples/plplot/f77/x16f.f
-share/examples/plplot/python/tutorpy
-share/examples/plplot/python/x01py
-share/examples/plplot/python/x02py
-share/examples/plplot/python/x03py
-share/examples/plplot/python/x04py
-share/examples/plplot/python/x05py
-share/examples/plplot/python/x06py
-share/examples/plplot/python/x07py
-share/examples/plplot/python/x08py
-share/examples/plplot/python/x09py
-share/examples/plplot/python/x10py
-share/examples/plplot/python/x11py
-share/examples/plplot/python/x12py
-share/examples/plplot/python/x13py
-share/examples/plplot/python/x14py
-share/examples/plplot/python/x15py
-share/examples/plplot/python/x16py
-share/examples/plplot/python/x17py
-share/examples/plplot/python/x18py
-share/examples/plplot/python/x19py
-share/examples/plplot/tcl/plgrid.tcl
-share/examples/plplot/tcl/plot.dat
-share/examples/plplot/tcl/plot.tcl
-share/examples/plplot/tcl/tcldemos.tcl
-share/examples/plplot/tcl/x01.tcl
-share/examples/plplot/tcl/x02.tcl
-share/examples/plplot/tcl/x03.tcl
-share/examples/plplot/tcl/x04.tcl
-share/examples/plplot/tcl/x05.tcl
-share/examples/plplot/tcl/x06.tcl
-share/examples/plplot/tcl/x07.tcl
-share/examples/plplot/tcl/x08.tcl
-share/examples/plplot/tcl/x09.tcl
-share/examples/plplot/tcl/x10.tcl
-share/examples/plplot/tcl/x11.tcl
-share/examples/plplot/tcl/x12.tcl
-share/examples/plplot/tcl/x13.tcl
-share/examples/plplot/tcl/x14.tcl
-share/examples/plplot/tcl/x15.tcl
-share/examples/plplot/tcl/x16.tcl
-share/examples/plplot/tk/Makefile
-share/examples/plplot/tk/tk01
-share/examples/plplot/tk/tk02
-share/examples/plplot/tk/tk03
-share/examples/plplot/tk/tk04
-share/examples/plplot/tk/tkdemos.tcl
-share/examples/plplot/tk/x01.tcl
-share/examples/plplot/tk/x02.tcl
-share/examples/plplot/tk/x03.tcl
-share/examples/plplot/tk/x04.tcl
-share/examples/plplot/tk/x05.tcl
-share/examples/plplot/tk/x06.tcl
-share/examples/plplot/tk/x07.tcl
-share/examples/plplot/tk/x08.tcl
-share/examples/plplot/tk/x09.tcl
-share/examples/plplot/tk/x10.tcl
-share/examples/plplot/tk/x11.tcl
-share/examples/plplot/tk/x12.tcl
-share/examples/plplot/tk/x13.tcl
-share/examples/plplot/tk/x14.tcl
-share/examples/plplot/tk/x15.tcl
-share/examples/plplot/tk/x16.tcl
-share/examples/plplot/tk/xtk01.c
-share/examples/plplot/tk/xtk02.c
-share/examples/plplot/tk/xtk04.c
-share/plplot/cglobe.map
-share/plplot/globe.map
-share/plplot/plstnd5.fnt
-share/plplot/plxtnd5.fnt
-share/plplot/usa.map
-share/plplot/usaglobe.map
+share/examples/plplot/plplot-test.sh
+share/examples/plplot/test_c.sh
+share/examples/plplot/test_cxx.sh
+share/examples/plplot/test_f77.sh
+share/examples/plplot/test_octave.sh
+share/examples/plplot/test_python.sh
+share/examples/plplot/test_tcl.sh
+share/plplot/data/cglobe.map
+share/plplot/data/globe.map
+share/plplot/data/plstnd5.fnt
+share/plplot/data/plxtnd5.fnt
+share/plplot/data/usa.map
+share/plplot/data/usaglobe.map
+@dirrm share/plplot/data
@dirrm share/plplot
-@dirrm share/examples/plplot/tk
-@dirrm share/examples/plplot/tcl
-@dirrm share/examples/plplot/python
@dirrm share/examples/plplot/f77
@dirrm share/examples/plplot/c
+@dirrm share/examples/plplot/c++
@dirrm share/examples/plplot
@dirrm share/doc/plplot
@dirrm include/plplot