summaryrefslogtreecommitdiff
path: root/math/parmetis/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /math/parmetis/Makefile
parentupdate to 20170510 (diff)
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'math/parmetis/Makefile')
-rw-r--r--math/parmetis/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/parmetis/Makefile b/math/parmetis/Makefile
index 0ddf4c758e20..a1580bac1b57 100644
--- a/math/parmetis/Makefile
+++ b/math/parmetis/Makefile
@@ -20,7 +20,7 @@ LICENSE_PERMS= auto-accept
OPTIONS_DEFINE= OPENMPI DOCS
OPENMPI_DESC= Use openmpi instead of mpich2
-USES= cmake gmake
+USES= cmake:noninja gmake
PLIST_FILES= include/parmetis/metis.h \
include/parmetis/parmetis.h \