summaryrefslogtreecommitdiff
path: root/math/parmetis/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
commit564a799c7173c288d4d3a9be78ac3d2db983d512 (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /math/parmetis/Makefile
parent- Remove MASTERDIR (diff)
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'math/parmetis/Makefile')
-rw-r--r--math/parmetis/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/parmetis/Makefile b/math/parmetis/Makefile
index cfe0c38c1ff5..c68a04b57114 100644
--- a/math/parmetis/Makefile
+++ b/math/parmetis/Makefile
@@ -22,7 +22,6 @@ OPENMPI_DESC= Use openmpi instead of mpich2
USES= cmake gmake
-MAKE_ARGS+= MAKEFLAGS=MAKE=${GMAKE}
PLIST_FILES= include/parmetis/metis.h \
include/parmetis/parmetis.h \
lib/parmetis/libmetis.a \
@@ -47,7 +46,8 @@ MPICC= ${LOCALBASE}/bin/mpicc
post-patch:
@${REINPLACE_CMD} -e \
's|BUILDDIR =.*|BUILDDIR = build| ; \
- s|make -C|${MAKE_CMD} -C|' ${WRKSRC}/Makefile
+ s|make -C|$$(MAKE) -C| ; \
+ s|$$(MAKEFLAGS)||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e \
's|"-O3"|""|' ${WRKSRC}/metis/GKlib/GKlibSystem.cmake