summaryrefslogtreecommitdiff
path: root/math/p5-Math-LinearCombination/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-05-27 14:52:23 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-05-27 14:52:23 +0000
commitcb5babcdc5e09b2858a4dc63137e8915eed25e74 (patch)
tree243e4ed728f8bce44085efd76586f808b546f73b /math/p5-Math-LinearCombination/Makefile
parentAdd p5-Math-SimpleVariable 0.03, (diff)
Add p5-Math-LinearCombination 0.03,
sum of variables with a numerical coefficient. PR: 32975 Submitted by: Sergey Skvortsov <skv@FreeBSD.org>
Diffstat (limited to 'math/p5-Math-LinearCombination/Makefile')
-rw-r--r--math/p5-Math-LinearCombination/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/p5-Math-LinearCombination/Makefile b/math/p5-Math-LinearCombination/Makefile
new file mode 100644
index 000000000000..34e2287aa3c8
--- /dev/null
+++ b/math/p5-Math-LinearCombination/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Math::LinearCombination
+# Date created: 5 Nov 2001
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-LinearCombination
+PORTVERSION= 0.03
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/fields.pm:${PORTSDIR}/devel/p5-Class-Fields \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Math/SimpleVariable.pm:${PORTSDIR}/math/p5-Math-SimpleVariable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::LinearCombination.3
+
+pre-patch:
+ @${FIND} ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ 's!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+!my !;'
+
+.include <bsd.port.mk>